xubuntu 6.06 to xubuntu 6.10 what happend!

Jelle de Jong jelledejong at powercraft.nl
Wed Nov 8 16:22:10 UTC 2006


I thought to day was a good day to migrate form dapper to edgy, because 
the nice updates in edgy are not available for dapper. And I wanted to 
do some debugging for edgy.

I am a pretty advanced user of linux and have a lot of program's and 
scripts installed.

I first tried edgy on my vmware system and it did work. so i give it a 
try. I made a dd image for backup if things went wrong.

I want to command line mode so i killed gdm en x

sudo apt-get update
sudo apt-get install xubuntu-desktop
sudo apt-get disk-upgrade

Then I configured the apt-get sources for edgy.

sudo apt-get update
sudo apt-get disk-upgrade

Here we went. Downloaded a lot of stuff > 1GB and started installing

I noticed that I recieved a lot of errors of these:
"perl: warning please check local settings"
I think this had to do with the fact that te program that sets the local 
settings was not run yet. later when the this program was run the 
warnings disappear. So someone could fix this "bug" by first setting 
local language settings for upgrading.

Then it happens the apt-get gives a error and quits

the error was in this package:

when I retried sudo apt-get disk-upgrade it advised me to run apt-get -f 
install so I did and it when on. after that i did a apt-get disk-upgrade 
again and it when further.

I got a warnings that there is something wrong with font gs.defoma line 
108. someone could check that.

When apt-get tried to restart mysql after upgrading something it hangs i 
waited 15 minutes and tryied some key combinations but the pc was dead.

I restarted the pc and the default kernel was broken and did not start.

I tried another kernel and got it to run single mode with lot of errors.
I restarted the apt-get disk-upgrade command

I got a error again and apt-get exits it was a error in the 

I concluded that this was not working. and wanted to restore my backup

so i tried a dd to restore my image (dd image is stored on another 
partion) but after a while the system was hanging again and I had to 

Now grub was totally down it gives me a error 16 code and does nothing.

I had not get burned a xubuntu 6.10 cd for a total clean install so i 
had to go to another pc and burn a alternate disk.

When I tried to load the kernel on the 6.10 alternate cd I got error:
apci kernel panic - not syncing.

I can remember this is the same error I got when I tried the a self 
compiled kernel, the newest from kernel.org. There is a bug somewhere 
with the new kernels and the via epia en12000 hardware.

I did not get tried to start the kernel with options like pci=noacpi and 
acpi=off. I will do that another time.

So far edgy experiences are very bad. Could some one please remove the 
fact from the xubuntu.org website that a dapper to edgy upgrade will go 
fine and give only advice for fresh installs.

I have spend a half a day for this and don't feel for making bug reports 
  other than this somebody other than me has to do that.

Hope edgy will improve in the future or do I have to wait 6 months for 
the next release? Keep up the good work btw.

Best regards,


More information about the xubuntu-devel mailing list