[ubuntu-za] Grub2 and other problems

Bill Cairns cairnsww at gmail.com
Thu Sep 26 13:10:31 UTC 2013

Thanks Miles - Boot-Repair does fix the Grub problem atfirst, but then it
comes back again. I have to assume a hardware problem.

On 25 September 2013 20:00, Miles <msdomdonner at gmail.com> wrote:

>  On 25/09/2013 16:18, Bill Cairns wrote:
>      I have being trying to get my 5 year old Mecer machine going again
> (it has been sitting gathering dust for a few months). But I seem to go
> back two steps for every one forward.
>  This machine used to run 10.04 with no problems. I had two hard disks  -
> a 160 GB drive (sdb) which I had partitioned sdb1 = root, sdb2 = swap and
> sdb3 = home. Then a 500 GB drive (sda) that I used as backup storage.
>  I started off trying to install Ubuntu 12.10 because that is a disk that
> I had easily available.  It ran beautifully in live mode.
> The installation took forever - it seemed to get stuck downloading updates
> to my existing packages. So I repeated the installation without connecting
> to the Internet.
> Again the installation seemed to go fine, but the machine booted to the
> point of asking for my password - it then refused to accept my password and
> would not go any further. OK so perhaps I mistyped my password or had a
> senior moment or something, so I re-installed. Same thing.
>  Hm. So I repeated the installation except this time I told it to format
> sdb1. Things went better and the machine accepted my password this time. In
> fact everything looked good and I thought that I had a working Ubuntu
> system. So I thought it was time to install all the updates that were
> missing. That took a few hours.
>  But now I had a new problem. The Unity GUI kept on just vanishing - the
> icons on the left and the tool bar on the top just vanished leaving me a
> completely useless machine. Sure, I could get a terminal window by
> CTl-ALT-T, but the terminal would not accept anything that I typed. I had
> to push the power button to shut the machine down and when I started it up
> again, the GUI vanished within seconds of my logging in.
>  I decided to cut my losses and start again. So I downloaded Xubuntu 13.04
> and tried it in live mode. It worked perfectly - I was particularly
> impressed that it found my wireless card and used it without problems
> whereas previously I had had to compile the driver. I installed and the
> installation went through. But on booting, I got the message "
> no such device d42bef6d ....
>  grub-rescue>
>  This is the point at which I am still stuck. I have Googled this and
> followed instructions to restore Grub, but get a variety of error messages
> depending on the sequence that I follow. I have tried telling the installer
> to forget the existing partitions on sdb and to use the whole drive - no
> change. I still get the "no such device" message.
>  I am tearing my hair. How can a new installation not be able to find Grub?
>  I am beginning to assume that I must have a hardware error. Any
> suggestions?
>  Thanks,
>    Bill
>  Hi Bill, I fix all boot-probs with a too called boot-repair,
> https://help.ubuntu.com/community/Boot-Repair
> Hope this helps you. Good luck.
> Miles
> --
> ubuntu-za mailing list
> ubuntu-za at lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-za
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-za/attachments/20130926/422291b9/attachment.html>

More information about the ubuntu-za mailing list