[ubuntu-za] Superuser

Walter Leibbrandt walter at translate.org.za
Thu Mar 4 07:44:35 GMT 2010

Op 04/03/2010 09:35, Darrel het geskryf:
> On Thu, 2010-03-04 at 09:07 +0200, Jan Groenewald wrote:
>> Hi
>> On Thu, Mar 04, 2010 at 09:03:25AM +0200, Darrel wrote:
>>> I have just loaded phpmyadmin with the idea of having a LAMP server to
>>> parse php files through Apache. My problem is that I cannot load any
>>> files into "/var/www" as I do not have permission. I have done some
>> You can use sudo to change the permission to your own, or you can add
>> yourself to the webserver "www-data" group, or you can work with sudo
>> each time.
>>> reading regarding the use of "sudo", "su" and "sudoers" but can't
>>> understand what the author is trying to explain.When I enter su in the
>>> terminal it requires a password,I assume this is a root password as my
>>> Linux password is not accepted.
>> No, it is your password. root password is disabled by default.
>>> How do I allocate myself a root password to become a superuser?
>> The person who installed is already a "sudoer", or in the "admin"
>> group. That person needs to add you:
>> sudo adduser darrel admin
>> Then user darrel also has sudo rights, with his own password.
>> Each admin task needs sudo in front.
>> sudo cp file /var/www/
>> You might prefer to keep a copy of the website in your home directory
>> and sync that periodically.
>> regards,
>> Jan
>> --
>>     .~.
>>     /V\     Jan Groenewald
>>    /( )\    www.aims.ac.za
>>    ^^-^^
> Thank you Andy and Jan, using sudo su - worked! I now have a root shell.
Btw, sudo -s does (pretty much) the same thing.
> Jan I tried sudo cp file /var/www/ and recieved "cp: cannot stat 'file':
> No such file or directory."
Let's break that command down...
"sudo" - Says "run this command as the root user"
"cp" - Copy
"file" - The file(s) to copy
"/var/www/" - Where you want to copy the file(s)

With the above breakdown, you should see that "file" (the 3rd part of 
the command) should be the filename or pattern of filenames of the 
file(s) that you want to copy. The error message implies says that there 
is no file called "file" in the current directory for the command to 
copy. Replace it with the name of the file you want to copy and you 
should be fine.

Walter Leibbrandt                  Software Developer
Recent blogs:
* Ubuntu PPA for Translate Toolkit and Virtaal

More information about the ubuntu-za mailing list