[ubuntu-za] Folder sharing

Robin Bownes robin at ncedatrust.org.za
Mon Apr 26 08:38:19 BST 2010

On Mon, 2010-04-26 at 08:45 +0200, Wesley Werner wrote:
> On Fri, Apr 23, 2010 at 10:38 AM, Robin Bownes
> <robinbownes at afrihost.co.za> wrote:
>         When I try to share a folder in my Home folder, I receive the
>         following error message when I ask Ubuntu to set the
>         permissions automatically.
>         'net usershare' returned error 255: net usershare add: cannot
>         convert name "Everyone" to a SID. Invalid parameter.
>         If you guys can tear yourselves away from the excitement of
>         the impending new release for a moment or two , I'd really
>         appreciate some help.
>         Thanks 
> Hi Robin, have a look if this Launchpad QA helps you out.
Thanks Wesley.

This wasn't quite what was needed, but while looking at things again,
they worked. What I realised was, that previously, the owner of my
Documents (and other Home folders) had been shown to be Root. Then when
I tried to set the permissions, it wouldn't allow me to do so.
Strangely, when I tried to set the permissions using gksu, it still did
not do so. For some reason, the system seems to have changed the
ownership of the folders back to me (primary user), and so I could
change the sharing settings today. I'm not sure whether to be happy that
I've been able to do so, or to be really nervous that permissions and
ownerships seem to be changing beyond my control - this feels a bit too
Windowish for my liking.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-za/attachments/20100426/2dddc1fd/attachment-0001.htm 

More information about the ubuntu-za mailing list