[ubuntu-za] nvidia drivers giving big issues

Reenen Laurie rlaurie at gmail.com
Thu Apr 23 21:26:54 BST 2009

Hi All,

I've been restarting my PC for more than the past 24 hours. (50 times?
more?)  Anyway, here is my tale, and I hope that someone could help me!

I always had an on-board intel graphics card, which well... was ok, but
kinda struggled with games.  So I got a 2nd hand 3d card off
gumtree.co.zawhich happens to be nvidia fx 5500 AGP. My pc is still
old enough, so it had
AGP slot.

Everything worked great!  I slotted it in, and when the PC rebooted, I got a
lovely 2048x1536 resolution (on my 21" monitor - CTX - don't really know the
brand), which high refresh rate.  Awesome!

My 3d games first pass worked (Half Life 1 - Counter strike, Open Arena, and
some others).  However... Starcraft ran hugely slow. 2-3 fps. I couldn't
follow my mouse cursor, it was so slow. Played around with settings (wine
regedit current user directdraw = "opengl" or "gdi" etc.), which needed
reboots - Starcraft didn't play well...

So, I checked for updates. Yes! Nvidia updates, as well as a kernel update,
as well as wine! Cool!  Ran updates, and restarted (for kernel).

When I had to log on, I was greeted with a 640x480 login screen where the
e's of my name didn't have a little hole... Since then, well I haven't been
able to use the PC, I have just been trying to fix it.

I've done several stuff... (in no particular order):
* sudo dpkg-reconfigure xserver-xorg
* installed new drivers, old drivers, vesa drivers (I got 800x600 with them)
* uninstalled all nvidia drivers
* added resolutions to /etc/X11/xorg.conf (and other xorg.conf edits and
* added some modules not to be loaded in
* Xorg -configure (from a non graphical shell)
* rebooted in recovery mode, asked to try to fix X
* played around with envyng

Some of the symptoms:
* My monitor is crt-0, where it used to have some name (can't recall what)

* dmesg | grep nvidia outputs:
[   16.402126] nvidia: module license 'NVIDIA' taints kernel.
[   17.057709] nvidia 0000:01:00.0: PCI INT A -> GSI 21 (level, low) -> IRQ

* glxinfo | grep render outputs:
direct rendering: Yes
OpenGL renderer string: GeForce FX 5500/PCI/SSE2

* xrandr outputs:
Screen 0: minimum 320 x 240, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   640x480        50.0     52.0
   320x240        51.0
   1024x768       52.0*
(note: the 1024x768 is a "panning" setting used to at least be able to use
the PC, the monitor is still at 640x480)

* lshw -C video outputs:
WARNING: you should run this program as super-user.
       description: VGA compatible controller
       product: NV34 [GeForce FX 5500]
       vendor: nVidia Corporation
       physical id: 0
       bus info: pci at 0000:01:00.0
       version: a1
       width: 32 bits
       clock: 66MHz
       capabilities: bus_master cap_list
       configuration: driver=nvidia latency=248 maxlatency=1 mingnt=5

I'm not a linux expert, and I've tredded in waters and places many an expert
hasn't gone yet. No avail. Why can't they make 3d capable open source

So now, even if I try to get back onto vesa drivers I'm stuffed.  I could
still go to my intel on-board, but even that doesn't reach the same
resolutions it used to in the past.  How did nvidia screw up my PC so badly?

Sorry, I am truely frustrated... could someone give me a similar experience
with a better result?

,_.>/ _
...speed is good
I believe five out of four people have a problem with fractions.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-za/attachments/20090423/56187b67/attachment.htm 

More information about the ubuntu-za mailing list