[ubuntu-x] elographics 2700, screen edges not activating

Daniel Caleb nix at tek12.com
Thu Mar 4 19:50:01 GMT 2010


I'm running 9.10 using the open source elographics driver on a 1515L
Elographics Intellitouch. 

ID 04e7:0020 Elo TouchSystems Touchscreen Interface (2700)

I've been noticing that the edges of the screen do not register touch
events. It's approximately 20 pixels from the edge all the way around. At
first I thought it had to be my minX/maxX settings... However, I've spent
many hours adjusting those - and I can center the mouse underneath the
touch event but still can not reach the outermost edge of the screen. 

The problem really manifests in an attempt to use the scroll bar on an
application, such as firefox or terminal. The cursor just does not move far
enough to the edge in order to activate the scrollbar. 

Here's the interesting part. I tried to using the touchscreen on a windows
box with the same result of not being able to move the cursor to the edge.
I then installed the elographics EAT (Edge Acceleration Tool) on a windows
machine and again adjusting the minX/maxX didn't make a difference.
Although there was an option to change "Cursor Acceleration", once this
option was moved to at least .5 the cursor was able to move all the way to
edge of the screen. 

So, it seems this is an issue that ELO fixed via their software, I was
wondering if this is a known issue? And, if there is a mysterious and
magical Xorg.conf incantation that I can use to emulate the EAT tool of

My current xorg.conf touchscreen section:

Section "InputDevice" 
Identifier "Touchscreen" 
Driver "elographics" Option "AlwaysCore" 
Option "Device" "/dev/input/elotouch"  
Option "debuglevel" "5" 
Option "MaxX" "3833" 
Option "MinX" "-16" 
Option "MaxY" "4133" 
Option "MinY" "25" 
Option "ReportingMode" "Raw" 
Option "SendCoreEvents" "On" 
Option "UntouchDelay" "10" 
Option "ReportDelay" "10"
# Option "SwapXY" "On"

I appreciate any input  regarding this issue... Thanks!

More information about the Ubuntu-x mailing list