[ubuntu-x] Testing legacy driver fix for Intel graphics

Alexey Efremov at gmail.com
Mon Aug 23 15:24:55 BST 2010

Freezed, but simptoms are slightly different. Before, my screen just
freezed, with cursor stopped moving. Now it's the same, except that my
screen turned black at the moment of freeze, showing only cursor.

On Mon, Aug 23, 2010 at 12:52 AM, Alexey Efremov < at gmail.com> wrote:
> Just tried to use legacy driver, but I can't boot with i915.modeset=0
> set. gdm tries to load, fails and reloads again, fails again etc.
> Without this line system loads fine. Testing the driver now (takes
> ~day to catch a new freeze usually, so can't tell right now if it
> helped)
> Ubuntu 10.04. My VGA controller details below:
> 00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series
> Chipset Integrated Graphics Controller (rev 07)
>        Subsystem: Lenovo Device 20e4
>        Flags: bus master, fast devsel, latency 0, IRQ 45
>        Memory at f2000000 (64-bit, non-prefetchable) [size=4M]
>        Memory at d0000000 (64-bit, prefetchable) [size=256M]
>        I/O ports at 1800 [size=8]
>        Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable+
>        Capabilities: [d0] Power Management version 3
>        Kernel driver in use: i915
>        Kernel modules: i915
> I tried to install Maverick backport (2.6.35-17) before, but it didn't
> help. Upgrading driver to 2.11.0 too.

More information about the Ubuntu-x mailing list