[ubuntu-x] Testing legacy driver fix for Intel graphics

Charles Barnwell cgbarnwell at gmail.com
Mon Aug 23 08:53:59 BST 2010

Tried implementing legacy driver for Intel chips in an LTSP
environment.  Without KMS the LDM screen attempts to write, but fails.
 Enabling KMS allowed me to get further, but still doesn't fix the
problem, I still get freezes.

Details of my graphics card:

00:02.0 VGA compatible controller: Intel Corporation
82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
        Subsystem: Dell Device 0126
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort-
<TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at e8000000 (32-bit, prefetchable) [size=128M]
        Region 1: Memory at ff680000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: [d0] Power Management version 1
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Kernel modules: i915

When i get the crash this is what I get in Xorg.7.log

(II) AIGLX: enabled GLX_MESA_copy_sub_buffer
(II) AIGLX: enabled GLX_SGI_make_current_read
(II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
(II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
(II) AIGLX: Loaded and initialized /usr/lib/dri/i915_dri.so
(II) GLX: Initialized DRI2 GL provider for screen 0
(II) intel(0): Setting screen physical size to 270 x 203

Fatal server error:
Failed to submit batchbuffer: Input/output error

Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.7.log" for additional

(II) AIGLX: Suspending AIGLX clients for VT switch
(II) intel(0): xf86UnbindGARTMemory: unbind key 0
 ddxSigGiveUp: Closing log

The consistent error I get is the

Fatal server error:
Failed to submit batchbuffer: Input/output error

Charles Barnwell
cgbarnwell at gmail.com

More information about the Ubuntu-x mailing list