[ubuntu-x] Can't build libgl1-mesa-dri from source?

Timo Aaltonen tjaalton at cc.hut.fi
Sat Feb 28 17:37:08 GMT 2009

On Sat, 28 Feb 2009, Martin Olsson wrote:

> Timo Aaltonen wrote:
>> You are likely missing some build dependencies. Either use debuild which 
>> should tell you what's missing. Then use 'apt-get build-dep mesa' to 
>> install them. Or use pbuilder which uses a chroot to build, so you don't 
>> have to mess with your installed system.
> Thanks a lot Timo, I got it to work now (or at least the build process
> runs a lot longer this time).
> I think the build-depends on the packages are in fact broken. I ran
> the apt-get build-dep command on both "mesa" and "libgl1-mesa-dri"
> and it said I had everything (see verbatim log from my terminal below).
> However, once I ran debuild as you said it did point out that I was
> missing lesstif2-dev. After installing the lesstif2-dev package my
> got past the nasty error.

Ok, so you tried to build the debian version with ubuntu build-deps. We 
don't build-depend on lesstif2-dev, because we don't build GLw (the 
security team don't want to support lesstif, so it's in universe). IOW, 
apt-get build-dep isn't enough in your case.


More information about the Ubuntu-x mailing list