modeset(0): Modeline "1680x1050"x0.0

Liam Proven lproven at gmail.com
Fri Nov 23 15:44:14 UTC 2018


On Fri, 23 Nov 2018 at 16:32, Chris <chris.pollock1948 at gmail.com> wrote:

> To be honest no I can't tell the difference however my eyes aren't the
> greatest either. Possibly if I tried a different Gnome theme I'd be
> able to.

Hmmm.

Generally, the image should fit _exactly_ onto the screen with no need
for any size or positioning adjustment. Any moiré patterning should
have disappeared. The image should blink into view instantly with no
delay for adjustment or sensing of picture size.

> > Silly question. You *did* remove the VGA cable, right?
> Yep :)

I've done it myself!

> That I'm not sure of however the question comes to mind that why did
> this only start when I upgraded from 16.04.5LTS to 18.04.1LTS? In fact
> it started as soon as I booted into the new version.

Well, I had this with about 13.04 or so.

Actually, hang on, I asked on the list...
*new Gmail tab*
*searches*
*gotcha*

I'll post it below my sig.

As you'll see, with a new version, screen detection failed.

I traced it: with a BNC to VGA cable, 12.04 just trusted me what the
screen was and let me set the resolution.
12.10 didn't. It tried to detect it, couldn't because the BNC cable
does not pass EDID infomation, and left me stuck in 640*480.

I had to replace the cable.

But it was working fine for several versions before that.

So, an analogous problem to yours.

> Do you see anything in the ~/.local/share/xorg/Xorg.0.log -
> https://pastebin.com/xdP4GY6G that could be the cause?

Is that the same one as before? It seems to be sensing via a VGA port.

-- 
Liam Proven - Profile: https://about.me/liamproven
Email: lproven at cix.co.uk - Google Mail/Hangouts/Plus: lproven at gmail.com
Twitter/Facebook/Flickr: lproven - Skype/LinkedIn: liamproven
UK: +44 7939-087884 - ČR (+ WhatsApp/Telegram/Signal): +420 702 829 053


-----


---------- Forwarded message ---------
From: Liam Proven <lproven at gmail.com>
Date: Sun, 18 Nov 2012 at 22:39
Subject: Quantal - unable to set screen resolution
To: Ubuntu user technical support, not for general discussions
<ubuntu-users at lists.ubuntu.com>


I installed 12.10 on my machine tonight - happily, in a separate
partition, replacing my old 11.10 install and leaving 12.04 in place.

I say happily because it's not working very well.

Firstly, the nVidia drivers wouldn't work. Trying to change or remove
them without a window manager was... /challenging/ but fortunately I
could open a terminal with Ctrl-Alt-t, even though I had no menu bar
or launcher.

Some digging around on the command line suggested that
gnome-control-center might be the "system settings" control panel.
(Why not call it "control centre" if that's its name?)

Anyway, I ran that, went to Software Sources, tried all the 4 nVidia
drivers on offer - current, current-updates, 304 and 310 - none
worked. I went back to Nouveau but now that only gave me 640*480 and
no ability to change.

Using my Mac, I found this very useful page:
http://techhamlet.com/2012/11/install-nvidia-drivers-in-ubuntu-12-10/

This enabled me to remove and reinstall them in a working manner.

Now I have my main screen running at 1600*1200 again.

The snag is, my second screen, the right-hand one, is stuck at 640*480.

I can find no way to change this - nVidia-settings seems to think this
is all it can do.

I think I know why; the right-hand screen is connected with BNC plugs,
the left hand one with a VGA-VGA cable. This means no EDID data is
getting back to the graphics card.

However, that doesn't help me. It worked fine in 12.04 and 11.10!

Anyone got any ideas how to fix this?

I don't have a spare VGA-VGA cable, but I will see if I can get one
and swap over... that might help. BNC gives better image quality,
though.



More information about the ubuntu-users mailing list