gparted questions

Bob ubuntu-qygzanxc at listemail.net
Mon Jun 25 17:54:28 UTC 2018


** Reply to message from Colin Law <clanlaw at gmail.com> on Mon, 25 Jun 2018
08:40:23 +0100

> On 25 June 2018 at 08:31, Bob <ubuntu-qygzanxc at listemail.net> wrote:
> > I had installed Ubuntu on a laptop that had a 500gb disk drive.  Finding the
> > hard drive too small for what I wanted to do I bought a 2tb drive and had it
> > installed in the laptop.  Used dd to copy the 500gb (atached via a USB adapter)
> > disk to the new 2tb disk.  The 2tb disk boots and runs most programs correctly.
> >
> > when i run gparted I get the following:
> >
> > robert at MARS:~$ sudo gparted
> > [sudo] password for robert:
> > Created symlink /run/systemd/system/-.mount ?åÆ /dev/null.
> > Created symlink /run/systemd/system/boot-efi.mount ?åÆ /dev/null.
> > Created symlink /run/systemd/system/home.mount ?åÆ /dev/null.
> > Created symlink /run/systemd/system/media-robert-Ubuntu\x2017.10\x20amd64.mount
> > åÆ /dev/null.
> > Created symlink /run/systemd/system/run-user-121.mount ?åÆ /dev/null.
> > Created symlink /run/systemd/system/tmp.mount ?åÆ /dev/null.
> > No protocol specified
> >
> > (gpartedbin:3740): Gtk-WARNING **: cannot open display: :0
> 
> Don't run graphical apps from a terminal with sudo(it might work with
> gksudo but that is also not recommended), run it from the GUI by, for
> example, hitting the WIN key and typing gparted.
> 
> Having run a graphical app using sudo you may have messed up file
> ownership in some files in your home directory. If you have problems
> with apps complaining then google for how to change all ownership back
> to yourself in your home directory.

I normally do not run GUI programs from the command line, I did it this time to
see why gparted does not run.  When I press the win key and type gparted and
then click the icon gparted starts.  There is icon on the status bar at the top
of the screen and a pop-up requesting my password, when I enter the password
gparted ends.  I ran gparted from the command line to see why it does not run.

-- 
Robert Blair


A government big enough to give you everything you want, is strong enough to take everything you have.  -- Thomas Jefferson



More information about the ubuntu-users mailing list