gparted questions

Bob ubuntu-qygzanxc at listemail.net
Mon Jun 25 07:31:21 UTC 2018


I had installed Ubuntu on a laptop that had a 500gb disk drive.  Finding the
hard drive too small for what I wanted to do I bought a 2tb drive and had it
installed in the laptop.  Used dd to copy the 500gb (atached via a USB adapter)
disk to the new 2tb disk.  The 2tb disk boots and runs most programs correctly.

when i run gparted I get the following:

robert at MARS:~$ sudo gparted
[sudo] password for robert: 
Created symlink /run/systemd/system/-.mount ?åÆ /dev/null.
Created symlink /run/systemd/system/boot-efi.mount ?åÆ /dev/null.
Created symlink /run/systemd/system/home.mount ?åÆ /dev/null.
Created symlink /run/systemd/system/media-robert-Ubuntu\x2017.10\x20amd64.mount
åÆ /dev/null.
Created symlink /run/systemd/system/run-user-121.mount ?åÆ /dev/null.
Created symlink /run/systemd/system/tmp.mount ?åÆ /dev/null.
No protocol specified

(gpartedbin:3740): Gtk-WARNING **: cannot open display: :0
Removed /run/systemd/system/-.mount.
Removed /run/systemd/system/boot-efi.mount.
Removed /run/systemd/system/home.mount.
Removed /run/systemd/system/media-robert-Ubuntu\x2017.10\x20amd64.mount.
Removed /run/systemd/system/run-user-1000.mount.
Removed /run/systemd/system/run-user-121.mount.
Removed /run/systemd/system/tmp.mount.
robert at MARS:~$ 

Now the only thing changed on the laptop was the hard drive so why can't
gparted work with the display?  It worked when the 500gb drive was in the
laptop.


Running qparted from a live 17.10 CD has no problems with the display.  The
500gb drive that was copied to the 2tb drive had free space in the middle of
the disk space and since the new drive is larger there is free space at the end
of the drive.  I want to now move partitions to the end of the 2tb disk.  As
far as I can see there is no way to tell gparted which free space to use when
moving a partition.  If the partition I try to move fits in the first free
space gparted will move ti there not to the free space at end of the drive. 
How do I get gparted to use the free space at the end of the disk drive?


Now that I have moved one partition it has a key symbol displayed and I can no
longer select "Resize/Move" for that partition.  I assume that the key symbol
indicates the partition is locked, how do I remove the lock so I can move it
again?

-- 
Robert Blair


My choices in life were either to be a piano player in a whore house or a politician. And to tell the truth, there's hardly any difference!  -- Harry Truman



More information about the ubuntu-users mailing list