problems with virtualbox

Peter petergoggin at bigpond.com
Sun Aug 12 00:21:36 UTC 2018


I now have one machine working correctly.

I stated by backing up my home directory which includes the VirtualBox 
VMs directory containing the virtual machine (in this case called NewXP)

I downloaded 64 bit ubuntu 16.04.

I did a clean install (wiping the disk clean), allowing updates during 
the install.

I then copied back my home directory which included the VirtualBox VMs 
directory.

I then downloaded from the Oracle site Virtual Box version 
5.2_5.2.16-123759 and the extension pack of the same version.

These were installed and I found that USB  did not work.

I then added my user name to vboxusers and now everything works.

Note that the install of 64 bit version did not add any components of 
VirtualBox, while with the 32 bit version regular updates added an 
incompatible version which screwed everything.

I would like to thank everyone for their help. Doing a full install of 
ubuntu and changing from 32 to 64 bit  and adding the user is probably 
the simplest option for me. At my age trying to remember Unix commands 
after a break of over 30 years is somewhat challenging.

Regards

Peter



On 11/08/18 20:25, Ralf wrote:
> On Sat, 2018-08-11 at 12:09 +0200, Ralf Mardorf wrote:
>> On Sat, 11 Aug 2018 09:52:28 +0100, Peter Hillier-Brook wrote:
>>> On 11/08/18 08:43, Ralf Mardorf wrote:
>>>> On Sat, 11 Aug 2018 10:55:53 +1000, Peter wrote:
>>>>> I added my user to vboxusers. This solves most of the problems
>>>>> [snip] I will start testing later today.
>>>> Don't count your chickens before they're hatched. Unlikely the issue
>>>> is solved.
>>> Why is everyone making such a meal of this? You can play with extension
>>> packs until the cows come home, but if you're not in 'vboxusers' you
>>> have no access to USB.
>> I did not mention anything against adding the user to the appropriate
>> group. It's already done, so why should I repeat something that
>> needs not to be done anymore? However, if the correct extensions
>> aren't available, you can't use USB 2.0, so at least this is needed,
>> too, to solve the issue.
>>
>> The link posted by Liam describes what to do, but doesn't explain why a
>> "ported back" "original virtual box" fails to access the required
>> extensions, even while it worked before. Actually nobody could know what
>> "ported back" "original virtual box" does mean. Were all virtual box
>> settings copied? Were virtual machines copied? Something else?
>>
>> If you read back the whole thread, you'll notice that it's not easy to
>> get useful information from the OP, most help is based on guessing.
>> Instead of following a step by step guide, by copying commands for
>> troubleshooting, the OP continues to do random actions without
>> understanding what he does.
>>
>> So what is wrong with mentioning that the extensions are _needed_
>> and explaining what likely is the culprit that it stopped working after
>> porting back settings? It can not work without the extensions.
> PS:
>
> I'm puzzled that it worked before porting back whatsoever, if the OP
> wasn't already member of the group 'vboxusers'. With this information in
> mind, it makes no sense to recommend adding the user to this particular
> group.
>
> The OP never mentioned that he was in this group and then removed
> himself from this group.
>
> The only thing we really could recommend is fixing the extension issue,
> since he explicitly mentioned:
>
> "If is sect USB 2.0 the machine will not start and complains about a
> possible incompatible version of the extension pack."
>
> FWIW the hint from Peter McD to care about the VBoxGuestAddition.iso to
> fix the USB issue is not useful at all, even without or wrong additions
> the guest shouldn't fail to start.
>
>
>




More information about the ubuntu-users mailing list