Upgrade problem after system failure, help please... **update**

Jay Ridgley jridgley2 at austin.rr.com
Thu Jan 26 15:52:21 UTC 2017


On 01/26/2017 06:53 AM, Ralf Mardorf wrote:
> On Thu, 26 Jan 2017 02:35:11 -0600, Jay Ridgley wrote:
>> sudo dpkg --configure -a
>> Setting up util-linux (2.27.1-6ubuntu3.2) ...
>> insserv: script hwclock.sh: service hwclock already provided!
>> insserv: exiting now!
>> update-rc.d: error: insserv rejected the script header
>> dpkg: error processing package util-linux (--configure):
>>  subprocess installed post-installation script returned error exit
>> status 1
>
> Strange, as a workaround the Internet e.g. provides
> BAD_INSSERV_HACKER=true dpkg-reconfigure insserv
> but I wouldn't use this workaround.
>
> Actually I'm running the same LTS as you and I don't experience the
> issue you experience.
>
> Google for all the above output, using one phrase of it, after the
> other.
>
>
>
Ralf

I got around the problem...

removed /etc/init.d/hwclock.sh
replaced it with a copy from another system
sudo apt-get install util-linux
sudo apt update
sudo apt upgrade

That worked!

A final sudo apt upgrade reported:

All packages are up to date.

Later I will reboot the system, if all is still well I will declare the 
problem solved.

Thanks,
Jay
-- 
Jay Ridgley
jridgley2 at austin.rr.com
Registered Linux User ID - 9115
https://linuxcounter.net/cert/9115.png
Registered Ubuntu User ID - 23320



More information about the ubuntu-users mailing list