systemd fails to boot most of the time

Tom H tomh0665 at gmail.com
Fri Feb 24 18:28:10 UTC 2017


On Fri, Feb 24, 2017 at 8:56 AM, Liam Proven <lproven at gmail.com> wrote:
> On 24 February 2017 at 14:41, Tom H <tomh0665 at gmail.com> wrote:


>> My first thought is to fsck your filesystems (although this wouldn't
>> explain the swap failure).
>
> Not speaking for Teresa -- but when I got this, yes, tried this. No
> problems, they were all clean and mountable.

OK.


>> My second thought is to rebuild your current initramfs:
>>
>> cd /boot
>> update-initramfs -ut -k $(name -r)
>
> But boots work, intermittently. As initramfs is RO, it can't be an
> error in that, can it?

The intermittnent success/failure is weird (and Ralph might be correct
in wonderting whather it's hardware-related) but I was thining that
the initramfs might have an incorrect fstab.


>> My third thought is to check the GUID types of your partitions ("Code" column):
>>
>> gdisk -l /dev/sda
>
> I checked that the IDs were correct. They were.

OK.


>> In theory (and I've tested it and it worked on my laptop), you can set
>> (with "t" in "gdisk /dev/sda")
>>
>> ef00 /boot/efi
>> 8200 swap
>> 8302 /home
>> 8304 / (for amd64)
>>
>> and they'll all be mounted without an entry in "/etc/fstab"
>
> Interesting -- what does this do?

I've forgotten what the exact rationale was but, IIRC, it was intended
to make "/etc/fstab" optional, especially for use-cases like a vm
manager or container manager. You can simply feed them a disk and its
partitions'll be mounted properly without you're having to maintain an
fstab.


>> Except perhaps a question: are the .device, .mount, or .swap units
>> auto-generated by systemd or are you providing them under /lib or
>> /etc?
>
> I don't know what these units are. Can you explain or point me at an
> explanation?

Run

find /run/systemd/ -name "*mount"
find /run/systemd/ -name "*swap"



More information about the ubuntu-users mailing list