systemd fails to boot most of the time

Gene Heskett gheskett at shentel.net
Fri Feb 24 15:55:13 UTC 2017


On Friday 24 February 2017 06:58:26 Teresa e Junior wrote:

> Em 24/02/2017 08:41, Liam Proven escreveu:
> > Yes, I've had this too, on 2 different machines. It's a pain.
> >
> > The only way around it that I found so far was to mount the
> > filesystems by hand, continue the boot, and then manually edit
> > /etc/fstab so it used device names not partition GUIDs. This seemed
> > to work more reliably, although not 100% of the time.
>
> I tried using device names like /dev/sda1 too, but then boot failed
> even earlier. Maybe it would have worked if I did not use the device
> name on the root partition too, since it seems I can boot normally
> with `noauto,x-systemd.automount` on all partitions except root.

Wrong... naming... Use (see man tun2fs) 'label' and pick something quasi 
unique. My drive for amanda's use as virtual tapes is labeled rather 
unimaginatively as

amandatapes

Its worked flawlessly now for in excess of a decade and 3 drives on the 
end of that cable. And I can do such things as:

gene at coyote:~/linuxcnc$ du -h /amandatapes
du: cannot read directory `/amandatapes/lost+found': Permission denied
16K	/amandatapes/lost+found
19G	/amandatapes/Dailys/slot12
19G	/amandatapes/Dailys/slot20
30G	/amandatapes/Dailys/slot23
31G	/amandatapes/Dailys/slot30
20G	/amandatapes/Dailys/slot1
20G	/amandatapes/Dailys/slot13
23G	/amandatapes/Dailys/slot4
20G	/amandatapes/Dailys/slot14
19G	/amandatapes/Dailys/slot26
30G	/amandatapes/Dailys/slot9
18G	/amandatapes/Dailys/slot10
19G	/amandatapes/Dailys/slot8
19G	/amandatapes/Dailys/slot21
19G	/amandatapes/Dailys/slot28
23G	/amandatapes/Dailys/slot18
19G	/amandatapes/Dailys/slot29
20G	/amandatapes/Dailys/slot5
19G	/amandatapes/Dailys/slot27
21G	/amandatapes/Dailys/slot15
23G	/amandatapes/Dailys/slot3
30G	/amandatapes/Dailys/slot2
19G	/amandatapes/Dailys/slot22
19G	/amandatapes/Dailys/slot19
31G	/amandatapes/Dailys/slot16
19G	/amandatapes/Dailys/slot7
19G	/amandatapes/Dailys/slot17
23G	/amandatapes/Dailys/slot25
19G	/amandatapes/Dailys/slot6
27G	/amandatapes/Dailys/slot11
19G	/amandatapes/Dailys/slot24
644G	/amandatapes/Dailys

Its a terabyte drive, with north of 64,000 spinning hours on it now.
Using blkid's may be ok, but its too volatile if something is changed.

When one needs to swap in a new drive, and do it with a simple act of 
commenting out that line in you fstab so it will boot. Shutdown, change 
drives, configure the new one to the same name, re-enable that line in 
fstab and do a hot reboot. amanda will have a tummy ache but can deal 
with it, or hang the old drive on another cable and copy as much as you 
can to the new drive. I've not had to do that for several years, 7.4 
according to my ti-30xIIs so my 82 yo wet ram is fuzzy.  Point being is 
that it Just Works(TM) 

Over that time frame, differences in how udev works have had that drive 
at 3 different /dev sdb|c|d addresses which did not effect the function 
in the least. AIR, its plugged into the sata4 jack on the motherboard.

Cheers, Gene Heskett
-- 
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>



More information about the ubuntu-users mailing list