systemd fails to boot most of the time

Teresa e Junior teresaejunior at gmail.com
Fri Feb 24 14:29:54 UTC 2017


Em 24/02/2017 10:56, Liam Proven escreveu:
> On 24 February 2017 at 14:41, Tom H <tomh0665 at gmail.com> wrote:
>
>> My first thought is to fsck your filesystems (although this wouldn't
>> explain the swap failure).
>
> Not speaking for Teresa -- but when I got this, yes, tried this. No
> problems, they were all clean and mountable.

Yes, I have run fsck in Emergency mode, it should not be the problem.

>> My second thought is to rebuild your current initramfs:
>>
>> cd /boot
>> update-initramfs -ut -k $(name -r)
>
> But boots work, intermittently. As initramfs is RO, it can't be an
> error in that, can it?

I don't think this is related, either. This problem has been happening 
for some time now, and Ubuntu automatically installs a new kernel every 
few days, so I think I went through a few different initramfs already.

>> My third thought is to check the GUID types of your partitions ("Code" column):
>>
>> gdisk -l /dev/sda
>
> I checked that the IDs were correct. They were.
>
>> In theory (and I've tested it and it worked on my laptop), you can set
>> (with "t" in "gdisk /dev/sda")
>>
>> ef00 /boot/efi
>> 8200 swap
>> 8302 /home
>> 8304 / (for amd64)
>>
>> and they'll all be mounted without an entry in "/etc/fstab"

I have just checked, and the partition types are all set appropriately. 
Are you sure the fstab entries can just be discarded like that? From 
what I know, partition types are set during system installation already.

>> Except perhaps a question: are the .device, .mount, or .swap units
>> auto-generated by systemd or are you providing them under /lib or
>> /etc?

How could I know this, please? My system is mostly the default, except 
that I had deleted my swap partition, and then later recreated it. Maybe 
the problem is related? But just commenting the swap entry in /etc/fstab 
did not change the problem.



More information about the ubuntu-users mailing list