systemd fails to boot most of the time

Liam Proven lproven at gmail.com
Fri Feb 24 13:56:28 UTC 2017


On 24 February 2017 at 14:41, Tom H <tomh0665 at gmail.com> wrote:

> My first thought is to fsck your filesystems (although this wouldn't
> explain the swap failure).

Not speaking for Teresa -- but when I got this, yes, tried this. No
problems, they were all clean and mountable.

> My second thought is to rebuild your current initramfs:
>
> cd /boot
> update-initramfs -ut -k $(name -r)

But boots work, intermittently. As initramfs is RO, it can't be an
error in that, can it?

> My third thought is to check the GUID types of your partitions ("Code" column):
>
> gdisk -l /dev/sda

I checked that the IDs were correct. They were.

> In theory (and I've tested it and it worked on my laptop), you can set
> (with "t" in "gdisk /dev/sda")
>
> ef00 /boot/efi
> 8200 swap
> 8302 /home
> 8304 / (for amd64)
>
> and they'll all be mounted without an entry in "/etc/fstab"


Interesting -- what does this do?

> Except perhaps a question: are the .device, .mount, or .swap units
> auto-generated by systemd or are you providing them under /lib or
> /etc?

I don't know what these units are. Can you explain or point me at an
explanation?


-- 
Liam Proven • Profile: https://about.me/liamproven
Email: lproven at cix.co.uk • Google Mail/Talk/Plus: lproven at gmail.com
Twitter/Facebook/Flickr: lproven • Skype/LinkedIn/AIM/Yahoo: liamproven
UK: +44 7939-087884 • ČR/WhatsApp/Telegram/Signal: +420 702 829 053



More information about the ubuntu-users mailing list