video card for new computer

Liam Proven lproven at gmail.com
Sun Dec 17 13:26:23 UTC 2017


On 17 December 2017 at 14:08, Peter Flynn <peter at silmaril.ie> wrote:
>
> I would STRONGLY recommend test-booting any potential system using a USB
> distribution before you buy. This will almost certainly reveal any problems.

Not possible with any kind of mail-order, of course.

> I have been searching for a Linux distribution which will install and boot
> on a Dell XPS 15 SSD. Almost all of them — including, I am sorry to say,
> *all* *ubuntu variants — fail completely even to boot from USB, as they hang
> halfway with the logo spinning/throbbing/whatever (Ubuntu hangs at the
> fourth dot changing colour),

Have you tried kernel parm acpi=off? Have you tried kernel parm nomodeset?

> and it does not provide a compatibility mode

Literally impossible. Windows 9x offered it because it was DOS-based
and could fall back to making BIOS calls instead of driving the
hardware directly. This is impossible for a 32-bit kernel so cannot be
implemented on WinNT or Linux or any other non-DOS-based OS.

> or
> terminal-only install.

There is one.

https://www.ubuntu.com/download/alternative-downloads

> The only two which actually boot from USB (and then only in compatibility
> mode) are Bodhi and Mint. Both of these install, but when you reboot, Bodhi
> gives a black screen and blinking cursor because it failed to install Grub.
> Mint Cinnamon was the only distribution which both installed the system,
> installed Grub, *and* updated the video drivers.
>
> I'm happy with that, but I would have been happier with *ubuntu. Omitting a
> compatibility-mode and terminal-mode installer was A Bad Idea IMNSHO.

As I have said, one thing exists and the other is impossible.

Have you updated the machine's firmware? That is troubleshooting step #1.

Also, disabling features with kernel commands, such as
kernel-modesetting, ACPI and so on. These are steps #2 and #3. You
have not mentioned them.

You said no Ubuntu variants worked -- but Mint itself is an Ubuntu variant.

Your message does not add up. It sounds like instead of trying to
resolve the problem, you just tried lots of distros until one worked.

-- 
Liam Proven • Profile: https://about.me/liamproven
Email: lproven at cix.co.uk • Google Mail/Talk/Plus: lproven at gmail.com
Twitter/Facebook/Flickr: lproven • Skype/LinkedIn/AIM/Yahoo: liamproven
UK: +44 7939-087884 • ČR/WhatsApp/Telegram/Signal: +420 702 829 053



More information about the ubuntu-users mailing list