Cannot run python3 scripts any more

Tony Arnold tony.arnold at
Mon Dec 11 22:10:35 UTC 2017

After today's updates, I did an apt autormove which tried to uninstall
the package python3-dbus.mainloop.qt, which failed. Since then, I've
tried to purge this packae, uninsytall it, re-install it and I get the

$ sudo apt purge python3-dbus.mainloop.qt
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED
0 to upgrade, 0 to newly install, 1 to remove and 0 not to upgrade.
1 not fully installed or removed.
After this operation, 65.5 kB disk space will be freed.
Do you want to continue? [Y/n] 
(Reading database ... 536635 files and directories currently
Removing python3-dbus.mainloop.qt (4.11.4+dfsg-2build2) ...
Segmentation fault (core dumped)
dpkg: error processing package python3-dbus.mainloop.qt (--remove):
 subprocess installed pre-removal script returned error exit status 139
Segmentation fault (core dumped)
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit
status 139
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

And now many python3 programs fail with segmentation fault immediately,
including commands such as pip3, for example.

Anyone else seen this? Anyone have a clue where to start?

All help gratefully received.

Tony Arnold MBCS, CITP | Senior IT Security Analyst | Directorate of IT Services | G64, Kilburn Building | The University of Manchester | Manchester M13 9PL | T: +44 161 275 6093 | M: +44 773 330 0039

More information about the ubuntu-users mailing list