[XENIAL] XOrg 1.18 is just terrible, many, many flickering! Chrome affected.

Martinx - ジェームズ thiagocmartinsc at gmail.com
Mon Mar 28 06:57:59 UTC 2016


 Since the upgrade on Xenial to XOrg 1.18, the screen does not stop
flickering! Especially Google Chrome window...

 It is near to impossible to use it now, it gives me headache...

 I am running Xenial on a brand new Macbook Pro (2015), under OSX, the
machine works just fine (but I don't like OSX, I prefer Ubuntu).

 Are you guys experiencing flickering with most recent Xenial too?

 I just recorded a video about this and uploaded to Youtube, as follows:


 The only workaround now, is to get rid of XOrg entirely, by using Ubuntu
GNOME + Wayland. Like this:

 sudo apt install gnome-session-wayland ubuntu-gnome-desktop desktop-base

 Then, reboot and select GOME + Wayland, problem solved!!!

 I also tried MIR:

 sudo apt install ubuntu-desktop-mir

 But it does not work at all, lightdm does not even start, I tried the
following instructions:


 But, it does not work. It said something like "Low resolution, fallback to
text" but, obviously this is a BUG, because my hardware supports both
Unity8 and Wayland, I don't know how to activate Unity 7 with XMIR on
Xenial, is looks broken now. Even the "Low resolution" message is displayed
under a very high resolution! Clearly a bug.

 I'm not used to GNOME, and also, when with Wayland, I am unable to lower
the resolution, it is very high and hard to read very small fonts.

 With Ubuntu 14.04, Google Chrome is unusable, due to issue:


 And now, once and again, 2 years later, Google Chrome is also very hard to
use on Ubuntu! Two LTS versions in a sequence that are very bad for
Chrome...   :-@

 Xenial was working okay before Xorg 1.18!! I'm glad that we have Wayland
on Ubuntu! Because Unity 7 on MIR also does not work.

 Chrome als works fine on 14.10, 15.04, 15.10... But not on 14.04, neither
on 16.04.

 I also tried "ppa:canonical-x/x-staging", no difference.

 I did not tried "
because Xenial is not supported yet.

 To be honest, I'm not sure if this problem is with XOrg 1.18, what I know
is that after upgrading to it, the problem appeared, and if I remove it, by
Wayland, the problem disappear but, I'm not 100% sure if this is a Xorg
problem, or not.

 The webpage that most triggers this problem is:

 I'm seeing this problem on my Macbook Pro and on a Samsung laptop, both
with Intel video boards.

 I'll try this week, on my PC running a Radeon PCI-e.

 I really appreciate any help! Sometimes, the entire desktop flickers! Not
only Google Chrome... But this is rare... A reboot "fix" this when it

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20160328/d972f0b7/attachment.html>

More information about the ubuntu-users mailing list