Battery Working, but not Charging

Teresa e Junior teresaejunior at gmail.com
Mon Jul 18 07:19:42 UTC 2016


Em 18/07/2016 03:16, Didik Setiawan escreveu:
> I've tried turn laptop on in variety of states, ac plugged-unplugged,
> discharging-recharging but battery still not charging. The only way
> to make it charging is boot on Windows and boot again using
> Ubuntu. But still, after I restart the laptop after using Ubuntu,
> I face the same problem again.

Batteries on newer Lenovo laptops can be configured on a software
available for Windows platforms. It is set to 60% by default, in order
to prolong the battery life. For Thinkpad users on Linux, TLP can change
the battery charge thresholds:
http://linrunner.de/en/tlp/docs/tlp-linux-advanced-power-management.html

My Lenovo is not a Thinkpad, though, but a Lenovo G40-80 (Lancer 4A1),
so I still haven't figured out how to solve this problem myself! Some
users just reset the CMOS to enable full charges, as in
http://askubuntu.com/questions/486595/lenovo-y510p-battery-wont-charge-past-60
, but I'd rather keep the health of the battery if possible!



More information about the ubuntu-users mailing list