Battery Working, but not Charging

Martin Weinberg martin.weinberg at comcast.net
Fri Jul 15 13:28:35 UTC 2016


I've seen many Thinkpads running 14.04 through 16.04 with out any
battery issues.  I'm familar with both an X220 and an T440s and they
both work correctly.  Specifically, the indicator-power panel app does
what it should.

The "Unknown" state is not necessarily a problem; for newer Thinkpads,
the acpi module isn't able to determine the state from the reported
battery info. For my X220, setting the thresholds (with tlp) causes acpi
to report "Unknown" when the charging stops at the desired threshold.  I
suppose that acpi module determines that the battery is not full, but
the charge is not increasing and calls it "Unknown".  Newer kernels seem
to call this "Unknown (threshold effective)", the last bit, I assume, to
provide a clue to the user about the cause of the "Unknown".

I suggest trying the laptop in a variety of states, ac plugged,
unplugged, discharging, recharging to make sure that you really have a
problem.

I also recommend looking at the output of "acpi -V" rather than "acpi"

Also, the output of "sudo tlp-stat" may provide some clues.


On 07/14/2016 11:23 PM, Didik Setiawan wrote:
> Dear All,
> 
> I have installed Ubuntu 16.04 64 bit on my Thinkpad laptop. Everything worked fine out of the box, except for the battery. The battery indicator on tray icon shows that battery working, but after wait for amount of time, it does not add the percentage of its capacity. I check with another way, using acpi command, it gives the following results:
> 
> $ acpi
> Battery 0: Unknown, 30%
> 
> The battery was normal if i switch to Windows. It could be charged using Thinkpad app on Windows. But, problem occured again when I using Ubuntu.
> I have searched through google, found some cases with same problem but none of them have an obvious solution.
> So, I want to ask question, the problem when I using Ubuntu come from userspace or kernelspace?
> As information, I've even tried to use vanilla kernel v4.6.2, but the result is nothing. How can I try to fix them?
> 
> Thanks.
> Didik Setiawan
> 
> 


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 473 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20160715/e6c4f437/attachment-0001.pgp>


More information about the ubuntu-users mailing list