Battery Working, but not Charging

Didik Setiawan ds at didiksetiawan.com
Fri Jul 15 03:23:41 UTC 2016


Dear All,

I have installed Ubuntu 16.04 64 bit on my Thinkpad laptop. Everything worked fine out of the box, except for the battery. The battery indicator on tray icon shows that battery working, but after wait for amount of time, it does not add the percentage of its capacity. I check with another way, using acpi command, it gives the following results:

$ acpi
Battery 0: Unknown, 30%

The battery was normal if i switch to Windows. It could be charged using Thinkpad app on Windows. But, problem occured again when I using Ubuntu.
I have searched through google, found some cases with same problem but none of them have an obvious solution.
So, I want to ask question, the problem when I using Ubuntu come from userspace or kernelspace?
As information, I've even tried to use vanilla kernel v4.6.2, but the result is nothing. How can I try to fix them?

Thanks.
Didik Setiawan




More information about the ubuntu-users mailing list