proprietary nvidia drivers broken since 16.04

Peter Silva peter at bsqt.homeip.net
Sat Jul 2 15:11:10 UTC 2016


Hi folks,

Have an optimus laptop (intel-4600 and nvidia-GT860M) that I used to
use for Steam Games, using intel as the boot GPU and nvidia (using
primusrun) only for games.  This took a long time to set up for 14.04,
but eventually it was fine.

I upgraded to (early version) of ubuntu 16.04 last November, and since
then, have been running only on intel, because every time I tried to
install nvidia
drivers, I just get a black screen.   Had been waiting for things to
stablize after release, but it looks like things are still just
massively broken.

The black screen has an underscore at the top-left of the normal X
(Ctrl-F7 or F8, not sure...) screen.   Ctrl-F1-6 gives me a totally
blank screen... so no tty access at all.   I normally have an ssh
server, but cannot ssh in when it is in this state either.

If I boot with nomodeset, then I get to a login screen, I enter the
password, and it just pops back to the login screen.  And there are
still no tty's...   So booted off of a USB media and used a chroot
environment to purge nvidia- drivers.

I see recipes to get out of the black screen... but all they do is
switch to nouveau drivers, which won't run games acceptably.    I am
looking to use the nvidia drivers to run games, but normally use
intel, as I did with 14.04.

Step 1:  any ideas on how to install the nvidia driver so that I have
a functioning system?



More information about the ubuntu-users mailing list