little radio driver needed

Nils Kassube kassube at gmx.net
Fri Jan 1 18:52:53 UTC 2016


Dave Stevens wrote:
> Quoting Nils Kassube <kassube at gmx.net>:
> > Usually the wireless network is configured with the network manager.
> > If you really want to do it manually, you should better use the
> > file "/etc/network/interfaces" to do that. But using network
> > manager is much easier.

> I have found a potentially useful message in dmesg (I don't know why I
> didn't look there first) like this:
> 
> [ 4293.353404] wlan0: authenticate with 00:1c:f0:f0:c3:18
> [ 4293.398731] wlan0: send auth to 00:1c:f0:f0:c3:18 (try 1/3)
> [ 4293.401167] wlan0: authenticated
> [ 4293.403511] mt7601u 1-1.4:1.0 wlan0: disabling HT as WMM/QoS is not
> supported by the AP
> [ 4293.403553] mt7601u 1-1.4:1.0 wlan0: disabling VHT as WMM/QoS is
> not supported by the AP
> [ 4293.413239] wlan0: associate with 00:1c:f0:f0:c3:18 (try 1/3)
> [ 4293.416990] wlan0: RX AssocResp from 00:1c:f0:f0:c3:18 (capab=0x421
> status=0 aid=2)
> [ 4293.457810] wlan0: associated
> [ 4293.460431] wlan0: disassociating from 00:1c:f0:f0:c3:18 by local
> choice (Reason: 3=DEAUTH_LEAVING)
> 
> 
> and I found a handy table here:
> 
> https://steev.wordpress.com/2010/03/31/deauthentication-reason-codes/
> 
> that tells me the access point went offline. I think that isn't the
> case because I'm continuously attached to the same AP as I write this,
> on my laptop.

Indeed it is probably another reason. I just tried to connect to my AP 
where I have setup a MAC filter. When I tried to connect from a client 
which was not in the list of allowed clients, I got the same "Reason: 
3=DEAUTH_LEAVING".

> Now, to answer your questions Nils.

[...]

> But the intended
> end-use was not like that, rather I want to strap a Raspberry Pi
> under a hexacopter with the dongle attached and then stream images
> from the rover back to another computer. So I switched to using the
> Pi from my laptop by ssh, hence the command line stuff.

Thanks for the details. I think in this case the suggested network 
manager wouldn't make much sense, it would probably not be too easy to 
configure it via ssh.

Another reason for the disconnects on the wlan0 interface could be that 
you still had the LAN on eth0 connected. I don't know what the Raspi 
would do then with an additional wlan0 interface while eth0 is still up.


Nils




More information about the ubuntu-users mailing list