Query about monitoring unknown Internet traffic

Bret Busby bret.busby at gmail.com
Mon Oct 19 04:45:23 UTC 2015


On 19/10/2015, Bret Busby <bret.busby at gmail.com> wrote:
> On 19/10/2015, Karl Auer <kauer at biplane.com.au> wrote:
>> On Mon, 2015-10-19 at 02:26 +0800, Bret Busby wrote:
>>> I assume that that means shutting down all the applications that are
>>> currently open.
>>
>> Yes - if you need a new login to your existing X server. I guess you
>> have to decide how likely it is that the traffic requires urgent
>> investigation.
>>
>> However, as previously mentioned, you DO NOT NEED to change groups to
>> use wireshark. Just run wireshark as root from a terminal window:
>>
>>    gksudo wireshark
>>
>> Regards, K.
>>
>
> I tried to run gksudo wireshark, but nothing happened, so, after a
> couple of minutes, I did <CTRL><C> .
>
> I am unfamiliar with the gksudo command.
>
> I then tried to run sudo wireshark , and got the following errore message.
>
> "Lua: error during loading:
> [string "/usr/share/wireshark/init.lua"]:46:dofile has been disabled
> due to running Wireshark as superuser.See
> http://wiki.wireshark.org/CaptureSetup/CapturePrivileges for help in
> running Wireshark as an unprivileged user."
>

Oh, and, after I sent this message (the one into which, I have
inserted this text), and clicked the <OK> button in the error dialogue
box, control (such as it is) was returned to the terminal, which then
displayed the line

"Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged."

and nothing further happened, so, once again, <CTRL<C> .

> So, it appears that wireshark can not be run as a superuser, and it is
> designed to be difficult to be run as an ordinary user.
>


-- 
Bret Busby
Armadale
West Australia
..............

"So once you do know what the question actually is,
 you'll know what the answer means."
- Deep Thought,
 Chapter 28 of Book 1 of
 "The Hitchhiker's Guide to the Galaxy:
 A Trilogy In Four Parts",
 written by Douglas Adams,
 published by Pan Books, 1992

....................................................



More information about the ubuntu-users mailing list