Dependencies error

Petter Adsen petter at synth.no
Sun Oct 4 07:07:15 UTC 2015


On Sat, 3 Oct 2015 15:21:04 +0200
Johnny Rosenberg <gurus.knugum at gmail.com> wrote:

> 2015-10-03 14:50 GMT+02:00 compdoc <compdoc at hotrodpc.com>:
> 
> > > I tried to install the MATE desktop environment in Ubuntu 14.04. I ran
> > the following lines:
> >
> >
> >
> >
> >
> > Might be too late, but this is how I install Mate on Ubuntu Server...
> >
> >
> >
> > sudo apt-add-repository -y ppa:ubuntu-mate-dev/ppa
> >
> > sudo apt-add-repository -y ppa:ubuntu-mate-dev/trusty-mate
> >
> >
> >
> > sudo apt-get update
> >
> >
> >
> > #Minimal install: (no un-needed services like Bluetooth, etc)
> >
> >
> >
> > sudo apt-get install --no-install-recommends mate-desktop-environment-core
> >
> >
> >
> > sudo reboot
> >
> 
> Well, the problem already occurred. I already installed Mate and I use it,
> but I can't install anything since I have that error thing, so I just
> wonder how to solve it.

Have you got aptitude installed? It sometimes does a better job than
apt-get at getting out of dependency hell since it uses different
algorithms. Use that to try removing the package 'libreoffice', since
that seems to depend on the rest of them.

If that fails, you could try to gather a list of the LibreOffice
packages that are installed and manually remove them with dpkg until
the dependencies resolve and apt-get can fix the rest.

Petter

-- 
"I'm ionized"
"Are you sure?"
"I'm positive."



More information about the ubuntu-users mailing list