kate NEARLY usable for remote files

Petter Adsen petter at synth.no
Thu Nov 26 18:13:03 UTC 2015


On Thu, 26 Nov 2015 18:02:54 +0100
robert <robert at redcor.ch> wrote:

> Hi friends in ubuntu,
> 
> my favourite programmers editor is kate.
> On of the main reasons (THE main reason, actually) is that it allows
> to edit remote files with perfect ease.
> Just open  it using an url that points to the file like 
> fish://root@remotebox.ch/etc/hosts (where fish:// is the protocol to
> use).
> 
> now the bad part:
> it does not work..
> at least, only clumsily ..
> 
> I have to open a remote file from a shell calling kate with the file
> as a parameter:
> kate fish://root@remotebox.ch/etc/hosts

Didn't we go over this back in May and again in August? I had a quick
look at the first posts of those threads, and you were using 15.04 then
- I'm assuming you have tried with 15.10 now?

> then it opens the file nicely, it even reloads it when the session is 
> reloaded at a later time.
> 
> So the edition of remote files works nicely. it is only the opening
> of remote files that is hard.
> 
> now my question..
> 
> where do I file that bug?

This is _probably_ not a problem with Kate itself, but rather part of
the framework (KIO?), so I'd assume it should be filed against whatever
package provides that. I'm not familiar enough with KDE to tell you
exactly which one, though it could be 'kio'.

Does it work in any other KDE applications - Konqueror, for example?
That should be checked first, so it can be filed against the correct
package. There could be a problem in how Kate uses KIO.

> or is there a way to circumvent it?

Have you tried with 'sftp' instead  of 'fish'? Or use sshfs.

If that doesn't work and nobody else here can think of something, you
could consider asking the folks at the kubuntu-users or kubuntu-devel
mailing lists, they are likely to be more familiar with the internals
of KDE.

Petter

-- 
"I'm ionized"
"Are you sure?"
"I'm positive."



More information about the ubuntu-users mailing list