Missing gstreamer packages

Colin Law clanlaw at gmail.com
Wed May 27 14:29:11 UTC 2015


On 27 May 2015 at 13:30, Petter Adsen <petter at synth.no> wrote:
> On Wed, 27 May 2015 13:19:47 +0100
> Colin Law <clanlaw at gmail.com> wrote:
>
>> On 27 May 2015 at 10:11, Petter Adsen <petter at synth.no> wrote:
>> > I'm trying to install some stuff on Xubuntu 15.04, among them some
>> > gstreamer plugins, and get this:
>> >
>> > Reading package lists... Done
>> > Building dependency tree
>> > Reading state information... Done
>> > Package gstreamer1.0-lame is not available, but is referred to by
>> > another package. This may mean that the package is missing, has been
>> > obsoleted, or is only available from another source
>> >
>> > Package gstreamer1.0-plugins-really-bad is not available, but is
>> > referred to by another package. This may mean that the package is
>> > missing, has been obsoleted, or is only available from another
>> > source
>> >
>> > E: Package 'gstreamer1.0-lame' has no installation candidate
>> > E: Package 'gstreamer1.0-plugins-really-bad' has no installation
>> > candidate
>>
>> Are you trying to install something from the Ubuntu repos?  If so
>> what?
>
> I'm still trying to trace down exactly what package Recommended these -
> they weren't hard Depends, but the thing that dragged them in was
> Cinnamon. From the repos.
>
> But even if they are only Recommends, it is still a dependency bug if
> they don't exist.

I notice that sound-juicer has the comments:
The package includes support by default for Vorbis and FLAC formats.
For other supports you need the following packages:
 * gstreamer1.0-plugins-ugly to encode to MP2,
 * gstreamer1.0-lame (not available in the Debian archive) to encode
   to MP3,
 * gstreamer1.0-plugins-really-bad (not available in Debian) to encode
   to AAC.

Could it be that?

Colin



More information about the ubuntu-users mailing list