Forcing static address in 12.04

rikona rikona at sonic.net
Thu Jun 11 04:15:08 UTC 2015


Hello Karl,

Wednesday, June 10, 2015, 5:06:48 PM, Karl wrote:

> On Wed, 2015-06-10 at 15:25 -0700, rikona wrote:
>> > OK - NetworkManager is NOT running. Good - makes things easier.
>> How did this tell you NM is not running?

> Because the only thing you saw with "NetworkManager" in it was the grep
> process you were running to look for it.

Aha - OK, thanks.

>> >            UP BROADCAST MULTICAST  MTU:1500  Metric:1
>> In the eth0 paragraph, there is a line EXACTLY as you have it above.

> Not so good. It needs to have "RUNNING" there as well.

When I last saw this it did have RUNNING in about the middle.

>> Those lines are not there. I even removed 2 comment lines to make what
>> I have be EXACTLY the same format as what you suggested.

> OK, that's a bit mystifying. But let's move on...

>> booted with no net. Today the 'trying..' msg did not appear and boot
>> was quicker. No idea why it is different.

> Because this time DHCP managed to get an address, I'd say. How does the
> ifconfig output look now?

>> Today, when I ping 192.168.144.233 I DO get a ping response, unlike
>> before [the lines look like the above except for the .233 address].
>> And a ping to 8.8.8.8 also DOES give me a response. I reported earlier
>> that the .233 did not work - the .8 didn't either but I didn't mention
>> it.

> Well, I'd say the network is working...

>> but ping sonic.net still gives

> ... but you don't have nameservers set up so it can't find "sonic.net".

I tried putting them in and it worked - I sent an earlier email
describing this.

> If you can ping 8.8.8.8 then your network is DEFINITELY working. Add
> nameserver entries to /etc/network/interfaces (in the eth0 section) and
> see how you go. And do this:

>    dig +short @8.8.8.8 sonic.net
>    ping <whatever address dig returns>

> I have no idea what you did to resolve this, but you seem to have done
> so.

I have no idea either! It's like it just started working in the last
of several 12.04 boots. Is there some kind of repair/fix process at
boot time? I've had this kind of thing happen on win boxes - after a
couple of boots, it starts working.

>> All the GUI network tools are still missing though.

> Try "sudo start network-manager" and see if network manager starts. You
> may have to run nm-applet too. However, with the right stuff
> in /etc/network/interfaces, you don't actually need Network Manager.

> Please send us your current /etc/network/interfaces file, and (now that
> you have access to the box) cut and paste the output from ifconfig as
> well.

Now running 14.04, continuing the prep. It's looking pretty good - may
change over even if 12.04 gets running well. I have 12.04 on one disk
and 14.04 on another. Is there a way I can put both in the box and
easily [not via the bios :-) ] select which one to boot from?

I'll try the above suggestions and send the above when I boot 12.04...

Many thanks for the help!

-- 

 rikona        




More information about the ubuntu-users mailing list