Forcing static address in 12.04

rikona rikona at sonic.net
Mon Jun 8 18:40:45 UTC 2015


Hello Karl,

Sunday, June 7, 2015, 10:31:13 PM, Karl wrote:

> On Sun, 2015-06-07 at 21:42 -0700, rikona wrote:

>> > - the output from "ifconfig | grep eth"
>> Just gives HW address, which is as expected.

> That's not the output; that's your interpretation of the output. Please
> post the actual output.

I don't have a way to copy the exact line - abbreviated a bit:
eth0 Link encap:Ethernet HWaddr d4:e3:...etc

>> > - the output from "grep eth /etc/udev/rules.d/70-persistent-net-rules"
>> no such file

> That's unusual. Can you search for a file called "*persistent-net*" and
> see if it is somewhere else?

locate gives me
/etc/udev/rules.d/70-persistent-net.rules         not quite the same

I don't have a way to copy the exact line - abbreviated a bit:
grep gives me
SUBSYS=="net", ACT'N=="add", DRIV=="?*" , ATTR =="d4:e3.." ,
ATTR{dev_id}=="0x0", ATTR[type}=="1", KERN=="eth*", NAME="eth0"

>> > - the output from "grep eth /etc/network/interfaces"
>> auto eth0
>> iface eth0 inet static
>> but that's after the blow up, before it was different/dynamic

> So you have not put things back the way they were before "the blow up"?

Probably not. The GUI tools I was using are not there any more, and
I'm not sure which CLI things need to be changed and what to change
them to.

Just checked - I did save a copy of the original 'interfaces' file
before I tried changing it:

auto lo
iface lo inet loopback

> Maybe tell us the steps you followed to cause "the blow up"?

Using the GUI tool initially I tried to change from 'auto' to 'fixed'
using the existing connection. As soon as I selected 'fixed' the
'save' button was grayed out - didn't make any difference what other
info I put in there - couldn't save the change.

I looked on the net and found 6-8 suggestions similar to the
/etc/network/interfaces procedure you mentioned below. Each suggestion
was a slight bit different. I tried a couple, each with different
msgs, and they didn't seem to do anything - still not a static address
as indicated by the GUI tools. The last slightly different one caused
the blow up.

>> > will not manage any interfaces that are defined
>> > in /etc/network/interfaces.
>> that was how it was initially

> "initially"? You mean before the "blow up" or before you changed
> routers?

The old router set IPs by mac address and was working fine for quite a
while - didn't need to look at the underlying details then. The
current 'interfaces' is much like you show below.

>> > - select the "Manual" method
>> as soon as I do this the 'save' is grayed out

> Yes - and it will stay that way until you enter valid details into the
> rest of the fields.

Even with all the info filled in it still was grayed out.

Just had a thought - via op error I had already inadvertently assigned
to another box the IP address [....8] I was trying to change it to,
but I didn't know that at the time. Could this have been the reason it
would not allow me to change it even with all the correct info added?
That box was online, and perhaps the 12.04 box knew that the [...8] IP
was already on the net.

> But if you don't have network manager any more it's
> a moot point.

It seems to be 'installed' and locate finds it in /etc/init.d. Htop
doesn't list it as such, but has 3 instances of nm-applet, if that's
what is actually run.

>> I didn't try this - it was the only operating connection and I was
>> afraid...

> Hang on - do you or do you not now have network manager running?

Not sure - is there a definitive way to tell?

>> > In /etc/network/interfaces, put something like this:
>> > auto eth0
>> > iface eth0 inet static
>> >    address 192.168.1.99
>> >    netmask 255.255.255.0
>> >    gateway 192.168.1.1
>> >    dns-nameservers 192.168.1.35
>> 
>> I tried this, with the right info, of course. This was in several net
>> suggestions.

> It is extremely unlikely that this would not work, *if* you have an eth0
> interface

I seem to... definitely did before the blow up...

> and *if* you put correct configuration details in. Please post
> the current contents of /etc/network/interfaces.

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.144.8
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.144.233
gateway 192.168.144.233
dns-nameservers 192.168.144.233

The above were the suggestions from the last net article[with my info
in there].


>> I have a thought in retrospect - I copied from the net, then changed
>> parts but not all. Could it be that the EOL or other chrs caused
>> problems?

> Unlikely.

>> >    sudo restart network-manager
>> got an error, didn't really understand it... didn't seem that bad

> For goodness sake. What was the actual error? What is the point of
> asking for help and then not providing information?!? If you "didn't
> really understand it", what on Earth makes you think it "didn't seem
> that bad?

I ran multiple suggested approaches and don't remember the exact msgs
from each one. Since the first ones didn't seem to change anything, it
didn't seem so bad.

>> > Then bring up the interface manually:
>> >    sudo ifup eth0
>> this is when the box blew up

> What exactly does "blew up" mean? Please be specific. Very specific.

The screen went nuts - windows were rapidly being switched to
different desktops, and at the end, every window was moved to another
desktop. Around half the pgms that were running had no window at all
and appeared to be closed. Some windows were not responding at all and
could not even be closed. The pgm icons on left screen no longer
worked. The top icon to shut down was not working. The open CLI window
was not responding. Maybe other details I don't recall now... Finally
just shut off power.

>> Doesn't look that good to me, given the result. :-)))

> Well it's a bit hard for us to tell, since you are not providing
> details.

> NetworkManager is a complex hairball of kludges and shortcuts. For
> dependability, go with /etc/network/interfaces every time.

That seemed to be what most of the net suggestions were, but I didn't
see that explicit statement. :-)

>> Agreed, and some are better than others. Figured this one out -
>> operator error. One was supposed to be .....18 and I had it in as
>> .....8 which was an address conflict. Worked OK when I did it
>> correctly. Could have saved waiting 2+ hours on the phone too. [goes
>> away grumbling...]

> So is your problem now solved via a DHCP reservation?

I have a new problem - no networking at all on that box. If it did,
the router fix might work as it had in the past. It has assigned the
proper IPs to other boxes, and the mis-assigned IP has been corrected.

Now I need to get networking back...

Thanks very much for the help!

-- 

 rikona        




More information about the ubuntu-users mailing list