HELP! Cannot use mouse or keyboard any more

Robert Heller heller at deepsoft.com
Sat Jun 6 19:02:20 UTC 2015


At Sat, 6 Jun 2015 11:07:53 -0700 "Ubuntu user technical support,  not for general discussions" <ubuntu-users at lists.ubuntu.com> wrote:

> 
> 
> 
> 
> On Sat, Jun 6, 2015 at 10:41 AM, Robert Heller <heller at deepsoft.com> wrote:
> 
> > Also, in grub you can edit the kernel command line and *remove* the 'quiet'
> > option.  This will result in a verbose bootup.  If something is failing, it
> > will be seen (and you will have an idea as to what might be broken).
> > Between
> > a verbose startup and a not-graphical login, almost all [linux] ills can be
> > cured (or at least diagnosed).
> >
> >
> I'll try that too.
> 
> Here's an interesting fact: when I put "text" on the end of the grub line,
> apache and sshd work for me.  When I don't, they don't.  I thought I had
> things going well, with an xorg.conf and everything, so I just rebooted.
> Back to the original problem, and my laptop's ssh reports "No route to
> host".
> 
> So I have to start with either "text" on the end of the line, or maybe
> "single" which I'll try next.  Maybe I'll get better info if I start X from
> single-user.
> 
> Well, I get to single-user mode OK.  The network is set up, but daemons are
> not running (there's a route now apparently, but connection refused on sshd
> and apache ports).  Startx brings up my 3 monitors (as root).  But this is

None of the deamons should be running in single user mode -- this is what 
single user mode is all about -- almost NOTHING is running.


> not normal.  If I log out of X, and exit from the single-user mode, I get
> to a console login prompt and my servers are running.  This is still not
> normal, but it's closer.  If I run startx from my user account, the result
> is almost normal, but the settings widget in the whishker menu is
> impoverished.  It doesn't have nVidia settings manager for instance.
> 
> So how could I get root to start an X login?  That is what is missing, and
> may be what is broken.

It still comes down to a problem with X11.

Try this:

take OFF 'quiet' and add 'text' to the boot (kernel) command line.  Watch what 
happens.  Warning things may go by fast, but any problems will show up with 
'FAILED' in red.  Note these down.

If the system come up to a console login with your server daemons running, log
in and run startx. If things continue to work after this, then the problem 
relates to whatever the Unity replacement for xdm (the X11 login 
daemon/manager) -- this is the only missing piece.

At worst, you might just as soon edit the grub conf to make 'text' the 
default boot option and live with a console login and use startx to fire up 
X11.

> 
> 

-- 
Robert Heller             -- 978-544-6933
Deepwoods Software        -- Custom Software Services
http://www.deepsoft.com/  -- Linux Administration Services
heller at deepsoft.com       -- Webhosting Services
                                         



More information about the ubuntu-users mailing list