HELP! Cannot use mouse or keyboard any more

Kevin O'Gorman kogorman at
Sat Jun 6 17:25:01 UTC 2015

Anybody know how to get into the nVidia config thing from the shell?  Or
the settings widget?

On Sat, Jun 6, 2015 at 10:02 AM, Kevin O'Gorman <kogorman at> wrote:

> On Sat, Jun 6, 2015 at 8:30 AM, Robert Heller <heller at> wrote:
>> At Sat, 6 Jun 2015 07:30:25 -0700 "Ubuntu user technical support,  not
>> for general discussions" <ubuntu-users at> wrote:
>> >
>> >
>> >
>> >
>> > Answering several suggestions:
>> >
>> > Ctl-Alt-F1 does nothing -- keyboard not working, after all
>> > Keyboard and mouse are USB.  Mobo has no PS/2
>> > Keyboard and mouse are unchanged, but I have tried spares.
>> > I have tried a previous kernel.  No help.
>> > I don't know how to boot into another user or session -- and unless it's
>> > something grub can do, I'm probably unable because of having no keyboard
>> > once the kernel starts
>> If you can get to grub (which you say you can), you should be able to
>> start in
>> single user mode, either by selecting 'rescue mode' or directly editing
>> the
>> boot line (add 'single' to the end of the kernel command line). I don't
>> know
>> if Ubuntu has a way of starting *without* X11 -- with CentOS and many
>> 'older'
>> Linux distros, this would be runlevel 3 (as opposed to runlevel 5) --
>> appending the kernel command line with '3' in grub would do that. Once in
>> single user mode (or non-graphical login mode) you can then change the
>> runlevel and/or disable graphical login (I don't know how to do that with
>> ?Ubuntu, but someone else on this list should be able to help with that).
>> You
>> can also poke around and look at various log files, etc.
>> *I* am NOT a fan of booting up to the GUI login -- all of *my* machines
>> boot
>> up to a (black) console login and I start X with xinit/startx *after* I
>> have
>> logged in, or in some cases don't start X at all (if I do not need to).
>> Also
>> all of *my* machine boot up verbosely, listing all of the start up steps,
>> etc.
>> If there is a problem I can watch for where things are broken.
>> It sounds like you have something fishy going on with the X Server.  And
>> possibly other issues as well, since Apache is not starting either.
>> >
>> > System is on a LAN, but unavailable.  It normally serves apache, but
>> that's
>> > not working either, which has me worried.  I would have thought the
>> server
>> > would be up whether I logged in or not.
>> It should be.  What do you mean by 'unavailable'? Can you ping the
>> machine (eg
>> does ping work or does ping claim the host is 'unavailable'?  If the
>> latter,
>> it sounds like there is a problem with the network interface(s) on the
>> machine.
>> I meant no response at all.  Ping couldn't find it (no route)  But I've
> now booted in text mode (appended "text" to grub "linux" line), and the
> server is working. Maybe I did something wrong the first time.
> Moreover, I can now log in from my laptop too and even do X forwarding, so
> I have a bit more control.
> --
> Kevin O'Gorman
> #define QUESTION ((bb) || (!bb))   /* Shakespeare */
> Please consider the environment before printing this email.

Kevin O'Gorman
#define QUESTION ((bb) || (!bb))   /* Shakespeare */

Please consider the environment before printing this email.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: image/gif
Size: 441 bytes
Desc: not available
URL: <>

More information about the ubuntu-users mailing list