Trying to set up encrypted swap

Petter Adsen petter at synth.no
Mon Feb 9 08:08:07 UTC 2015


Hi!

I'm trying to set up encrypted swap on my 14.10 machine with
"ecryptfs-setup-swap". I have two swap partitions of 4GB each, on
separate SSD's. Here's the output:

root at fenris:~$ ecryptfs-setup-swap 

WARNING:
An encrypted swap is required to help ensure that encrypted files are
not leaked to disk in an unencrypted format.

HOWEVER, THE SWAP ENCRYPTION CONFIGURATION PRODUCED BY THIS PROGRAM
WILL BREAK HIBERNATE/RESUME ON THIS SYSTEM!

NOTE: Your suspend/resume capabilities will not be affected.

Do you want to proceed with encrypting your swap? [y/N]: y

INFO: Setting up swap: [/dev/sdb2]
WARNING: Commented out your unencrypted swap from /etc/fstab
INFO: Setting up swap: [/dev/sdc2]
WARNING: Commented out your unencrypted swap from /etc/fstab
stop: Unknown instance: 

And then it just sits there. I started this last night, and it's still
not finished, doesn't produce any output, and there is no significant
load. From what I can see, there's nothing in the logs either.

What does the "stop: Unknown instance:" mean? It can't be taking 10+
hours to complete, so what do I do? Kill it and start again?

I'd really appreciate any advice.

Petter

-- 
"I'm ionized"
"Are you sure?"
"I'm positive."
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 213 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20150209/ebdb6912/attachment.pgp>


More information about the ubuntu-users mailing list