problems upgrading 14.04 to 14.10 (configuration failures in sysv-rc & grub packages)

Marius Gedminas marius at pov.lt
Tue Nov 4 17:54:35 UTC 2014


On Tue, Nov 04, 2014 at 01:46:09PM +0000, Adam Funk wrote:
> I tried to upgrade a machine remotely using 'sudo do-release-upgrade'
> in screen.  That crapped out as follows:
> 
> #v+
> Errors were encountered while processing:
>  sysv-rc
>  grub-common
>  grub-pc-bin
>  grub-pc
>  grub2-common

Ouch.  I wouldn't try rebooting before you get this resolved.

> I tried running it again with the same results, then 'sudo aptitude
> update && sudo aptitude safe-upgrade', which ended up with this:
> 
> #v+
> Unable to resolve dependencies for the upgrade because the resolver timed out.
>   You may be able to solve this problem by increasing
>   Aptitude::ProblemResolver::StepLimit (currently 500000).
> Unable to safely resolve dependencies, try running with --full-resolver.
> #v-

Aptitude is not recommended for Ubuntu, try apt-get upgrade instead.

> Fine, let's try 'sudo aptitude safe-upgrade --full-resolver'
> ... failed with this:
> 
> #v+
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> A package failed to install.  Trying to recover:
> Setting up sysv-rc (2.88dsf-41ubuntu18) ...
> info: Reordering boot system, log to /var/lib/insserv/run-20141104T1340.log
> error: Something failed while migrating.
> 
> error: Unable to migrate to dependency based boot sequencing.
> 
> See http://wiki.debian.org/LSBInitScripts/DependencyBasedBoot for
> more information about dependency based boot sequencing. To
> reattempt the migration process run 'dpkg --configure sysv-rc'.
> 
> dpkg: error processing package sysv-rc (--configure):
>  subprocess installed post-installation script returned error exit status 1
> Setting up grub-common (2.02~beta2-15) ...
> update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
> insserv: Script virtuoso-nepomuk is broken: missing end of LSB comment.
> insserv: exiting now!

A-ha!

> What do I have to do now to get this thing upgraded?

Remove or fix /etc/init.d/virtuoso-nepomuk and run

  sudo dpkg --configure -a

Since http://packages.ubuntu.com/search?keywords=virtuoso-nepomuk shows
that virtuoso-nepomuk was removed from the Ubuntu archive at some point
after the 12.04 release, removing the file and/or apt-get purge'ing the
remains of the package seems like the right thing to do:

  sudo apt-get purge virtuoso-nepomuk

> Or will I have
> to waste a day or two copying data off it & doing a fresh
> installation?

Hopefully not.

> PS: Thanks a lot, Canonical, for diverting effort into fooling around
> with the GUIs.

Yeah, this is a painful upgrade bug and something ought to be done.
Please file a bug with

  ubuntu-bug release-upgrade

Marius Gedminas
-- 
If you are good, you will be assigned all the work.  If you are real
good, you will get out of it.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 190 bytes
Desc: Digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20141104/772f67e5/attachment.pgp>


More information about the ubuntu-users mailing list