nullmailer - Sending failed: Could not exec program (Solved)

Graham Watkins at
Sun Jun 22 10:50:14 UTC 2014

On 21/06/14 15:48, Graham Watkins wrote:
> Hi folks,
> Continuing to try to get RKhunter to mail it's log to me.
> I've installed nullmailer and configured (or misconfigured) it. However,
> I am not receiving mails and sudo nullmailer-send brings up the following:
> Rescanning queue.
> Starting delivery, 8 message(s) in queue.
> Starting delivery: protocol: --port=25 host: file:
> 1403360941.3155
> Sending failed: Could not exec program
> and so on for each message I've tried to send.
> My nullmailer remotes file looks like this:
> --port=25 at
> --pass=<mypassword>
> (password details removed)
> I suspect that this may be where the fault lies as configuration
> instructions tend towards vague.
> If anyone can point out where I might be going wrong. I'd appreciate it.
> If it matters, I am using version 1.1.11-2.1
> Cheers,
> Graham
Hello again,

Just thought you might like to know that I've managed to successfully 
send a test mail using nullmailer.

I gave up trying to do it using and used instead. My /etc/nullmailer/remotes file now looks like this: smtp --port=465 --auth-login 
--user=<myusername> --pass=<mypassword> --ssl

I didn't particularly want to use gmail but as it works I guess I can 
live with it.

I found the following tutorials quite useful:

- much more so than the official nullmailer documentation.

Thanks to compdoc and Gene Heskett for trying to help.



More information about the ubuntu-users mailing list