Help! I cannot upgrade to New Ubuntu release 12.04.4 LTS

Nils Kassube kassube at
Mon Apr 28 04:45:59 UTC 2014

Rick Magraw wrote:
> rsm at rsm-laptop:~$ df
> Filesystem           1K-blocks      Used Available Use% Mounted on
> /dev/sda5              8120500   6868972    842276  90% /
> /dev/sda7             59601088    316532  56280808   1% /home

> > > I have freed up copious amounts of disk space and emptied the
> > > trash
> > > over the past day, but I still get exactly the same error message:

Just a side note: The trash is in your $HOME (no pun intended), not the 
root directory. Therefore it makes no difference if you empty the trash.

> > > Not enough free disk space
> > > The upgrade has aborted.
> > > The upgrade needs a total of 3.377 M of free space on disk '/'
> > > Please free at least an additional space of 2.528 M on disk '/'

I don't think there is a chance to clean up that much space. Therefore 
it is a bit tricky to make it work. You could mount an external disk 
partition to the directory "/var/cache/apt/archives/" before you try the 
upgrade again. That directory is where the downloaded packages for the 
new release are stored. If you use e.g. an empty 4GB USB stick, I would 
format the partition with ext2 for this purpose because I'm not sure if 
all filenames of the packages are compatible with FAT32.


More information about the ubuntu-users mailing list