upgrade solves other issues?

John R. Sowden jsowden at americansentry.net
Tue Apr 8 10:38:09 UTC 2014

On 04/08/2014 03:07 AM, Colin Law wrote:
> On 8 April 2014 10:44, John R. Sowden <jsowden at americansentry.net> wrote:
>> On 04/08/2014 12:45 AM, Colin Law wrote:
>>> On 7 April 2014 21:11, John R. Sowden <jsowden at americansentry.net> wrote:
>>>> I am having a problem whereby gcc and other low level programs cannot be
>>>> upgraded (even by root).  I have written about this before with varying
>>>> responses.  I do not want to (unless I _have_ to) remove Ubuntu from my
>>>> computer and "reinstall the operating system", as Microsoft says.  I will
>>>> not know what programs I have added, written, etc. over the years that
>>>> will
>>>> be lost.  Will upgrading to 14.04 solve this issue?
>>> That rather depends on what the problem you currently have is.  Remind
>>> us of the problem and someone may be able to answer.
>>> Colin
>>>> Also what directories will be left alone?
>>>> John
>> It started when I was noticing when I did Ubuntu updates, there were base
>> updates (binutils) that I was unable to select.  After a while of no luck, I
>> gave up (computer was working ok).
> Let's go back to square one, does
> sudo apt-get update
> show any errors? If so then post them.
> If not, what does
> sudo apt-get dist-upgrade
> show?  Copy/paste it here.
> Colin
john at sentry10:~$ sudo apt-get update
[sudo] password for john:
Ign http://us.archive.ubuntu.com saucy InRelease
Ign http://archive.canonical.com saucy InRelease
Ign http://us.archive.ubuntu.com saucy-updates InRelease
Hit http://archive.canonical.com saucy Release.gpg
Ign http://us.archive.ubuntu.com saucy-security InRelease
Hit http://archive.canonical.com saucy Release
Get:1 https://private-ppa.launchpad.net saucy InRelease [349 B]
Ign https://private-ppa.launchpad.net saucy InRelease
Ign http://us.archive.ubuntu.com saucy-backports InRelease
Hit http://archive.canonical.com saucy/partner i386 Packages
Ign https://private-ppa.launchpad.net oneiric InRelease
Hit http://us.archive.ubuntu.com saucy Release.gpg
Get:2 http://us.archive.ubuntu.com saucy-updates Release.gpg [933 B]
Hit https://private-ppa.launchpad.net saucy Release.gpg
Get:3 http://us.archive.ubuntu.com saucy-security Release.gpg [933 B]
Hit https://private-ppa.launchpad.net oneiric Release.gpg 

Get:4 http://us.archive.ubuntu.com saucy-backports Release.gpg [933 B] 

Hit https://private-ppa.launchpad.net saucy Release 

Hit http://us.archive.ubuntu.com saucy Release 

Hit https://private-ppa.launchpad.net oneiric Release 

Get:5 http://us.archive.ubuntu.com saucy-updates Release [49.6 kB] 

Hit https://private-ppa.launchpad.net saucy/main i386 Packages 

Get:6 http://us.archive.ubuntu.com saucy-security Release [49.6 kB] 

Get:7 https://private-ppa.launchpad.net saucy/main Translation-en_US 
[371 B]
Get:8 http://us.archive.ubuntu.com saucy-backports Release [49.6 kB] 

Hit http://us.archive.ubuntu.com saucy/main i386 Packages 

Hit https://private-ppa.launchpad.net oneiric/main i386 Packages 

Ign http://archive.canonical.com saucy/partner Translation-en_US 

Hit http://us.archive.ubuntu.com saucy/restricted i386 Packages 

Get:9 https://private-ppa.launchpad.net oneiric/main Translation-en_US 
[378 B]
Ign http://archive.canonical.com saucy/partner Translation-en 

Hit http://us.archive.ubuntu.com saucy/universe i386 Packages 

Hit http://us.archive.ubuntu.com saucy/multiverse i386 Packages 

Hit http://us.archive.ubuntu.com saucy/main Translation-en 

Hit http://us.archive.ubuntu.com saucy/multiverse Translation-en 

Hit http://us.archive.ubuntu.com saucy/restricted Translation-en 

Hit http://us.archive.ubuntu.com saucy/universe Translation-en 

Get:10 http://us.archive.ubuntu.com saucy-updates/main i386 Packages 
[223 kB]
Get:11 http://us.archive.ubuntu.com saucy-updates/restricted i386 
Packages [14 B]
Get:12 http://us.archive.ubuntu.com saucy-updates/universe i386 Packages 
[160 kB]
Get:13 http://us.archive.ubuntu.com saucy-updates/multiverse i386 
Packages [1,773 B]
Ign https://private-ppa.launchpad.net saucy/main Translation-en_US 

Hit http://us.archive.ubuntu.com saucy-updates/main Translation-en 

Ign https://private-ppa.launchpad.net saucy/main Translation-en 

Ign https://private-ppa.launchpad.net oneiric/main Translation-en_US 

Hit http://us.archive.ubuntu.com saucy-updates/multiverse Translation-en 

Ign https://private-ppa.launchpad.net oneiric/main Translation-en 

Hit http://us.archive.ubuntu.com saucy-updates/restricted Translation-en 

Hit http://us.archive.ubuntu.com saucy-updates/universe Translation-en 

Get:14 http://us.archive.ubuntu.com saucy-security/main i386 Packages 
[107 kB]
Get:15 http://us.archive.ubuntu.com saucy-security/restricted i386 
Packages [14 B]
Get:16 http://us.archive.ubuntu.com saucy-security/universe i386 
Packages [37.3 kB]
Get:17 http://us.archive.ubuntu.com saucy-security/multiverse i386 
Packages [1,395 B]
Hit http://us.archive.ubuntu.com saucy-security/main Translation-en 

Hit http://us.archive.ubuntu.com saucy-security/multiverse 
Hit http://us.archive.ubuntu.com saucy-security/restricted 
Hit http://us.archive.ubuntu.com saucy-security/universe Translation-en 

Get:18 http://us.archive.ubuntu.com saucy-backports/restricted i386 
Packages [14 B]
Get:19 http://us.archive.ubuntu.com saucy-backports/multiverse i386 
Packages [709 B]
Get:20 http://us.archive.ubuntu.com saucy-backports/main i386 Packages 
[2,140 B]
Get:21 http://us.archive.ubuntu.com saucy-backports/universe i386 
Packages [4,680 B]
Hit http://us.archive.ubuntu.com saucy-backports/main Translation-en 

Hit http://us.archive.ubuntu.com saucy-backports/multiverse 
Hit http://us.archive.ubuntu.com saucy-backports/restricted 
Hit http://us.archive.ubuntu.com saucy-backports/universe Translation-en 

Ign http://us.archive.ubuntu.com saucy/main Translation-en_US 

Ign http://us.archive.ubuntu.com saucy/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com saucy/restricted Translation-en_US
Ign http://us.archive.ubuntu.com saucy/universe Translation-en_US
Ign http://us.archive.ubuntu.com saucy-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com saucy-updates/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com saucy-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com saucy-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com saucy-security/main Translation-en_US
Ign http://us.archive.ubuntu.com saucy-security/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com saucy-security/restricted Translation-en_US
Ign http://us.archive.ubuntu.com saucy-security/universe Translation-en_US
Ign http://us.archive.ubuntu.com saucy-backports/main Translation-en_US
Ign http://us.archive.ubuntu.com saucy-backports/multiverse 
Ign http://us.archive.ubuntu.com saucy-backports/restricted 
Ign http://us.archive.ubuntu.com saucy-backports/universe Translation-en_US
Fetched 689 kB in 1min 41s (6,788 B/s)
Reading package lists... Done
john at sentry10:~$


>> Then I tried to install Pure Basic.  It would not install.  It creates
>> assembler code (i think), then compiles it into an executable.  This would
>> not work because it uses gcc or an associated computer.  I went on this list
>> and this is the last message (most complete) that I got in response to
>> various executions I ran:
>> On 03/15/2014 05:26 AM, Liam Proven wrote:
>>> On 14 March 2014 23:20, John R. Sowden <jsowden at americansentry.net> wrote:
>>>> It seems that my problem has to do with "held" files (from synaptic) but
>>>> I
>>>> cannot determine which files are "held" so I can delete them.
>>> I Am aware that Synaptic was my own suggestion - but if you try
>>> from the shell with apt-get, then you can fairly easily copy-and-paste
>>> the errors here...
>> I went to the site you suggested.  It seems that others have had the same
>> issue, but it has not
>> been resolved.  It seems that this is where the Ubuntu staff should step in.
>> I appreciate your stepping
>> back into the confusion.  I am almost ready for the microsoft "reinstall the
>> operating system" solution.
>> below is a synaptic error message after trying to "fix broken packages"
>> E: Unable to correct problems, you have held broken packages.
>> E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused
>> by held packages.
>> E: Unable to correct dependencies
>> E: Unable to correct problems, you have held broken packages.
>> E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused
>> by held packages.
>> Below is an apt-get error message after running apt-get build-essential:
>> The following packages have unmet dependencies:
>>   build-essential : Depends: gcc (>= 4:4.4.3) but it is not going to be
>> installed
>>                     Depends: g++ (>= 4:4.4.3) but it is not going to be
>> installed
>> E: Unable to correct problems, you have held broken packages.
>> It seems that the program knows what messages are "held" but is not showing
>> them,
>> nor is it showing the command to see them (often done).
>> If I try to delete gcc, it want to delete a lot of libraries that are
>> associated with gcc, and therefore,
>> without those libraries, about 100 valid programs will be deleted because if
>> dependencies.
>> It seems like there is a old version of gcc on the computer which is causing
>> this chain of events.
>> I tried to manually remove gcc, but could not (as root, I did not have
>> permission).
>> By the way, for several months, whenever an upgrade came along, the Ubuntu
>> base section
>> had binutils, and assembler listed but were unchecked.  It would not allow
>> me to check them.
>> I am also getting hundreds of errors on boot each day, ever since I turned
>> on the display of the
>> initial programs.  The errors reference "fd 7" and bad directory or file
>> name.  The normal execution
>> of the system does not seem to be effected (libreoffice, thunderbird,
>> firefox, printing)
>> ============================================
>> tia, John
>> --
>> ubuntu-users mailing list
>> ubuntu-users at lists.ubuntu.com
>> Modify settings or unsubscribe at:
>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

More information about the ubuntu-users mailing list