Ruby and ri(1) ruby information

Kevin O'Gorman kogorman at
Sat Dec 21 23:37:53 UTC 2013

On Sat, Dec 21, 2013 at 3:14 PM, Kevin O'Gorman <kogorman at> wrote:
> On Sat, Dec 21, 2013 at 1:37 AM, Colin Law <clanlaw at> wrote:
>> On 21 December 2013 09:27, Kevin O'Gorman <kogorman at> wrote:
>>> On Sat, Dec 21, 2013 at 1:13 AM, Colin Law <clanlaw at> wrote:
>>>> ...
>>>> # install dependencies
>>>> sudo apt-get install build-essential bison openssl libreadline6
>>>> libreadline6-dev curl git-core \
>>>> zlib1g zlib1g-dev libssl-dev libyaml-dev libxml2-dev autoconf
>>>> libc6-dev ncurses-dev automake \
>>>> libtool
>>>> # install rvm, ruby and rails
>>>> curl -L | bash -s stable
>>>> See for info on rvm.  The above may be a little out of date as
>>>> I think rvm now includes an autolibs facility that means you don't
>>>> need to manually install the dependencies, but the above should still
>>>> work.
>>>> When using rvm any gems install command should be run without sudo.
>>> So when I do the bit that says, inter alia, that it installs ruby:
>>> what happens to the existing packages ruby1.9.1 and libruby1.9.1?
>> Nothing.  It installs a new ruby in your home directory under .rvm.
>> So, for example, when I run which ruby I see
>> $ which ruby
>> /home/colinl/.rvm/rubies/ruby-1.9.3-p194/bin/ruby
>> The original system ruby (if installed) will still be there but will
>> not normally be used as .rvm appears in the path first.
>> Colin
> No joy.  I did all that, and I now have a .rvm directory and modified
> .bashrc.  But ruby is still /usr/bin/ruby, and .rvm/bin does not
> contain a replacement.
> --
> Kevin O'Gorman


I should also say I am interested in getting the Xubuntu installation
to work more than I am in just getting my own account to work.

Also, I have just installed Saucy on a laptop, fresh 64-bit install.
I tried some things, I forget which, and one of them pointed me at the
package ruby1.9.1-full and on installing that, everything worked.

So I went back to this machine running Raring, and find that while I
have ruby1.9.1 installed (and it's an Ubuntu package) I do not have
ruby1.9.1-full installed, and it is NOT an Ubuntu package.  On
installing ruby1.9.1-full, I find all these problems have gone away.

It seems to me that Ubuntu should either drop ruby1.9.1 or adopt the
full version as well.  What they have now is an embarrassment.

Kevin O'Gorman

programmer, n. an organism that transmutes caffeine into software.
Please consider the environment before printing this email.

More information about the ubuntu-users mailing list