install gparted on Ubuntu 8.10

lazer100 lazer100 at
Mon Sep 17 09:42:29 UTC 2012

On 17-Sep-12 10:14:36 Nils Kassube wrote:
>lazer100 wrote:
>> when I try
>> df -h
>> I get:
>> Filesystem            Size  Used Avail Use% Mounted on
>> /dev/sda3             9.7G  2.5G  6.8G  27% /
>> tmpfs                 2.0G     0  2.0G   0% /lib/init/rw
>> varrun                2.0G   84K  2.0G   1% /var/run
>> varlock               2.0G     0  2.0G   0% /var/lock
>> udev                  2.0G  2.9M  2.0G   1% /dev
>> tmpfs                 2.0G  104K  2.0G   1% /dev/shm
>> lrm                   2.0G  2.4M  2.0G   1%
>> /lib/modules/2.6.27-7-generic/volatile
>> /dev/sdb1             7.5G  5.8G  1.8G  78% /media/QUICK
>> /dev/sda1              49G   43G  6.8G  87% /media/disk
>> but its not showing the system drive which is about 500G, that must
>> be /dev/sda

>/dev/sda is the entire disk but the df command only shows mounted 

>> and it doesnt show the 1 terabyte drive I want to zero, which is
>> unformatted currently:

>If it is unformatted it can't be mounted and therefore you can't see it 
>with the df command. Use

>sudo fdisk -l

>instead to list the wanted information for all your disks.

this has worked, when I used the command it echoes:

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x41fe41fd

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        6374    51199123+   7  HPFS/NTFS
/dev/sda2            6375       12748    51199155    6  FAT16
/dev/sda3           12749       14023    10241437+  83  Linux
/dev/sda4           14024       14660     5116702+   f  W95 Ext'd (LBA)
/dev/sda5           14024       14660     5116671   82  Linux swap / Solaris

Disk /dev/sdb: 8029 MB, 8029470208 bytes
255 heads, 63 sectors/track, 976 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1         976     7839698    b  W95 FAT32

Disk /dev/sdc: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/sdc doesn't contain a valid partition table

thus /dev/sda is the system drive, and /dev/sdc is the 1tb drive I mentioned.

I'll try to zero the drive later as this is quite time consuming,

Linux zeroing is the only practical way to wipe a drive, as you cannot
wipe data on Windows,

on Windows even if you delete files, empty the recycle bin, delete partitions,
create new partitions with different boundaries, fully reformat these,
most of the files and directories will all be there if you use a good
salvage program such as File Scavenger 4.0!

there is a video on YouTube which shows someone doing a full reformat
of a volume and retrieving all the original files with the above program,
I tried this out myself and the video is correct, I successfully viewed photos
the drive salvaged by the program.

I bought some file wiping Windows software which also wipes drives,
but it wipes the sectors using the same strange multipass algorithm
used for files, I wanted to do 32 passes, but even after 8 hours
it hadnt even completed 1 percent!

>> unfortunately if I try tab completion with /dev/ ie to press tab
>> after this, it lists various things but none of the drives,
>> I think that is a defect with the implementation of tab completion,

>IMHO the tab completion works quite well but in the /dev folder there 
>are not only disks listed but all devices known to the system, so tab 
>completion won't show only what you are looking for. You could try 
>/dev/sd and then tab because then you limit the selection to disks.

on trying this what I found is that tab completion of /dev/ and /dev/sd show
the drives
but only if you do this in context eg:

dd if=/dev/[tab]


dd if=/dev/sd[tab]

show all the drives, but if you try:

$ /dev/[tab]


$ /dev/sd[tab]

it doesnt show the drives

I am used to a computer system where tab completion shows everything
of context,

anyway, you have successfully answered every question I asked on this topic 
in various emails!

More information about the ubuntu-users mailing list