System bell ignoring preferences

Nils Kassube kassube at gmx.net
Fri Sep 14 04:54:39 UTC 2012


Dotan Cohen wrote:
> On Thu, Sep 13, 2012 at 10:57 PM, Nils Kassube <kassube at gmx.net> 
wrote:
> > You are using the default values of the beep program which should
> > be the same both times. If you want to test the system sound for
> > the bell, use the command
> > 
> > echo -e "\a"
> 
> Thanks. Unfortunately, that makes no sound at all! The pcspkr module
> is loaded: $ lsmod | grep pcspkr
> pcspkr                 12702  0
> 
> And I made sure that the bell is on:
> 
> $ xset b on
> 
> But still no sound! I also tried echo ^V^G but no bell either. Why
> might that be?

I tried it yesterday on a 12.04 machine and I got a bell sound from a 
terminal program and from a virtual console. So it should be possible to 
enable it. However if I try it with this 10.04 machine I get no sound in 
a terminal, only in a virtual console (after "modprobe pcspkr"). I 
suppose I have disabled the system sound somewhere in the Kubuntu 
settings because I don't like it. However when I just tried to enable 
it, I couldn't find a setting which works. Maybe someone else has an 
idea?


Nils




More information about the ubuntu-users mailing list