[xubuntu 12.04] Update-manager produces segmentation fault

Robert Spanjaard spamtrap at arumes.com
Sat Sep 8 20:51:31 UTC 2012

On my netbook with Xubuntu 12.04 installed, update-manager suddenly won't 
run anymore. I first noticed it when I tried to run it earlier today from 
the "updates available" notification. It used the CPU for a couple of 
seconds, and then I got the "crash detected" notification.
When I try to run update-manager from the command line, I get 
"Segmentation fault (core dumped)".

Some things I already considered:
1. Update Manager is the only program that fails. Other package managers 
like Software Center, apt-get and Synaptic run flawlessly.
2. Memtest doesn't report any errors. Still, I tried a spare memory 
module just to be safe, but I got the same error.
3. Through Google, I found that removing the contents of /var/cache/apt 
solved the problem for some people. But not for me.
4. I tried reinstalling update-manager and update-manager-core from 
freshly downloaded packages (ofcourse, after point 3, the cache was 
empty). Still got the same error. :-(

Any ideas left for me to try?

Regards, Robert                                      http://www.arumes.com

More information about the ubuntu-users mailing list