problems with 10.04 upgrade to 12.04

NoOp glgxg at
Fri Sep 7 16:30:14 UTC 2012

On 09/07/2012 04:07 AM, Dave Howorth wrote:
> Marius Gedminas wrote:
>> On Thu, Sep 06, 2012 at 04:03:19PM +0100, Dave Howorth wrote:
>>> Marius Gedminas wrote:
>>>> Can you try
>>>>   apt-get install -o APT::Immediate-Configure=false -f apt python-minimal update-manager-core vim-gnome
>>>>   apt-get install -o APT::Immediate-Configure=false -f apt python-minimal python2.7 libpython2.7 libperl5.14 tcl8.5
>>>> It'll most likely fail with an slightly different error message, but
>>>> maybe we'll discover (eventually) why apt fails to resolve the
>>>> dependencies.
>>> I tried both of those and attached the logs at
>> Ok, that looks like the wrong path to take.  Clearly listing all the
>> packages it fails to install by hand is not going to work.
>> I'm now looking at the bug comments trying to find the error from
>>   apt-get install -o APT::Immediate-Configure=false -f
>> and I don't see it.  Did you try this command?  Can you?
>> Marius Gedminas
> Woohoo! You're a genius Marius (or else it will all end in tears :) )
> I haven't run that particular variation before - haven't seen it
> anywhere AFAIK and nobody's asked me to run it. Anyway it's now doing a
> lot of unpacking and replacing and processing so hopefully it is making
> some progress. More later when it finishes.

Perhaps you should have read the bug report that I pointed you to
several days ago... :-)

urusha (urusha) wrote on 2012-04-29: 	#3

I got the same error when I tried to 'do-release-upgrade' from lucid to
For me workaround was:
sudo apt-get -f install -o APT::Immediate-Configure=false
And after this run 'do-release-upgrade' again.

That command is the same as:
apt-get install -o APT::Immediate-Configure=false -f

Glad to see that it's starting the update - I'll hold off on upgrading
the 10.04 that I installed.

Regarding your python warnings:
[python-support not cleaning up during Lucid -> Precise upgrade]
Unfortunately he wasn't able to reproduce it at the time... However, he
did in this bug report:
[Lucid -> Precise upgrade does not clean up files]
The reporter is a dev...
Fixed in 2010 on maverick (10.10) but not for lucid (10.04):
[Warnings on python-support while upgrade ]
Seems like python has some real issues...

Regarding your 'Failed to parse default value:

Regarding the 'Setting locale failed' - are you still doing all of this
via ssh?

More information about the ubuntu-users mailing list