Quantal - unable to set screen resolution

blind Pete 0123peter at gmail.com
Wed Nov 21 02:51:01 UTC 2012

Liam Proven wrote:

> On 19 November 2012 08:07, blind Pete <0123peter at gmail.com> wrote:
>> Liam Proven wrote:
>>> I installed 12.10 on my machine tonight - happily, in a separate
>>> partition, replacing my old 11.10 install and leaving 12.04 in place.
>>> I say happily because it's not working very well.
>>> Firstly, the nVidia drivers wouldn't work. Trying to change or remove
>>> them without a window manager was... /challenging/ but fortunately I
>>> could open a terminal with Ctrl-Alt-t, even though I had no menu bar
>>> or launcher.
>> Isn't the reason that you spend so much time on the computer
>> because you enjoy the challenge?  >:->
> Er, yeah... Something like that... :¬/
>>> Some digging around on the command line suggested that
>>> gnome-control-center might be the "system settings" control panel.
>>> (Why not call it "control centre" if that's its name?)
>>> Anyway, I ran that, went to Software Sources, tried all the 4 nVidia
>>> drivers on offer - current, current-updates, 304 and 310 - none
>>> worked. I went back to Nouveau but now that only gave me 640*480 and
>>> no ability to change.
>> Vesa should also be an option.
> But probably not a very good one.

A very low performance, but highly likely to work option.  
Is "nv" still a possibility?  

>>> Using my Mac, I found this very useful page:
>>> http://techhamlet.com/2012/11/install-nvidia-drivers-in-ubuntu-12-10/
>>> This enabled me to remove and reinstall them in a working manner.
>>> Now I have my main screen running at 1600*1200 again.
>>> The snag is, my second screen, the right-hand one, is stuck at 640*480.
>>> I can find no way to change this - nVidia-settings seems to think this
>>> is all it can do.
>> Probably, but check the logs and be certain.  Also type "xrandr".
> OK, will do when home again later.
>> Try adding these to 'Section "Monitor"' of /etc/X11/xorg.conf,
>>     Option         "ModeDebug" "True"
>>     Option         "ModeValidation" "AllowNonEdidModes"
>>     Option         "UseEdid" "False"
>> Make sure that the other values are sensible, ESPECIALLY the
>> horz. and vert. frequencies.  Then reboot and read /var/log/Xorg.0.log,
>> it is really boring, but informative.  Then you might want to
>> run nvidia-bug-report.sh.
>>> I think I know why; the right-hand screen is connected with BNC plugs,
>>> the left hand one with a VGA-VGA cable. This means no EDID data is
>>> getting back to the graphics card.
>> Nvidia have recently got a bit cranky about only using modes listed
>> in the EDID.  There is a flag in some versions of EDID that states
>> whether or not the monitor can handle gtf modes in general or just
>> the listed modes - and it is often wrong.
> Oh really? I did not know this & have heard nothing about it.. Perhaps
> I need to get a VGA-VGA cable as a priority.

If you can't lay your hands on one immediately you can experiment 
by swapping connections.  

Most people are perfectly satisfied with a single screen mode and 
wouldn't notice if they only had one.  It is only the visually 
impaired who like to do a "hardware zoom" with <ctl><alt><keypad+> 
who would notice.  

If it does prove to be a BNC thing then it qualifies as an 
annoying bug, and please report it.  

>>> However, that doesn't help me. It worked fine in 12.04 and 11.10!
>>> Anyone got any ideas how to fix this?
>> Just guessing.
> Useful looking info tho' - thanks!

Here's hoping that I am as useful as I am verbose.  


More information about the ubuntu-users mailing list