Quantal - unable to set screen resolution

blind Pete 0123peter at gmail.com
Mon Nov 19 08:07:08 UTC 2012

Liam Proven wrote:

> I installed 12.10 on my machine tonight - happily, in a separate
> partition, replacing my old 11.10 install and leaving 12.04 in place.
> I say happily because it's not working very well.
> Firstly, the nVidia drivers wouldn't work. Trying to change or remove
> them without a window manager was... /challenging/ but fortunately I
> could open a terminal with Ctrl-Alt-t, even though I had no menu bar
> or launcher.

Isn't the reason that you spend so much time on the computer 
because you enjoy the challenge?  >:-> 

> Some digging around on the command line suggested that
> gnome-control-center might be the "system settings" control panel.
> (Why not call it "control centre" if that's its name?)
> Anyway, I ran that, went to Software Sources, tried all the 4 nVidia
> drivers on offer - current, current-updates, 304 and 310 - none
> worked. I went back to Nouveau but now that only gave me 640*480 and
> no ability to change.

Vesa should also be an option.  

> Using my Mac, I found this very useful page:
> http://techhamlet.com/2012/11/install-nvidia-drivers-in-ubuntu-12-10/
> This enabled me to remove and reinstall them in a working manner.
> Now I have my main screen running at 1600*1200 again.
> The snag is, my second screen, the right-hand one, is stuck at 640*480.
> I can find no way to change this - nVidia-settings seems to think this
> is all it can do.

Probably, but check the logs and be certain.  Also type "xrandr".  

Try adding these to 'Section "Monitor"' of /etc/X11/xorg.conf, 

    Option         "ModeDebug" "True"
    Option         "ModeValidation" "AllowNonEdidModes"
    Option         "UseEdid" "False"

Make sure that the other values are sensible, ESPECIALLY the 
horz. and vert. frequencies.  Then reboot and read /var/log/Xorg.0.log, 
it is really boring, but informative.  Then you might want to 
run nvidia-bug-report.sh.  

> I think I know why; the right-hand screen is connected with BNC plugs,
> the left hand one with a VGA-VGA cable. This means no EDID data is
> getting back to the graphics card.

Nvidia have recently got a bit cranky about only using modes listed 
in the EDID.  There is a flag in some versions of EDID that states 
whether or not the monitor can handle gtf modes in general or just 
the listed modes - and it is often wrong.  

> However, that doesn't help me. It worked fine in 12.04 and 11.10!
> Anyone got any ideas how to fix this?

Just guessing.  

> I don't have a spare VGA-VGA cable, but I will see if I can get one
> and swap over... that might help. BNC gives better image quality,
> though.

blind Pete
Sig goes here...  

More information about the ubuntu-users mailing list