Quantal - unable to set screen resolution

Liam Proven lproven at gmail.com
Sun Nov 18 21:39:25 UTC 2012

I installed 12.10 on my machine tonight - happily, in a separate
partition, replacing my old 11.10 install and leaving 12.04 in place.

I say happily because it's not working very well.

Firstly, the nVidia drivers wouldn't work. Trying to change or remove
them without a window manager was... /challenging/ but fortunately I
could open a terminal with Ctrl-Alt-t, even though I had no menu bar
or launcher.

Some digging around on the command line suggested that
gnome-control-center might be the "system settings" control panel.
(Why not call it "control centre" if that's its name?)

Anyway, I ran that, went to Software Sources, tried all the 4 nVidia
drivers on offer - current, current-updates, 304 and 310 - none
worked. I went back to Nouveau but now that only gave me 640*480 and
no ability to change.

Using my Mac, I found this very useful page:

This enabled me to remove and reinstall them in a working manner.

Now I have my main screen running at 1600*1200 again.

The snag is, my second screen, the right-hand one, is stuck at 640*480.

I can find no way to change this - nVidia-settings seems to think this
is all it can do.

I think I know why; the right-hand screen is connected with BNC plugs,
the left hand one with a VGA-VGA cable. This means no EDID data is
getting back to the graphics card.

However, that doesn't help me. It worked fine in 12.04 and 11.10!

Anyone got any ideas how to fix this?

I don't have a spare VGA-VGA cable, but I will see if I can get one
and swap over... that might help. BNC gives better image quality,

Liam Proven • Profile: http://lproven.livejournal.com/profile
Email: lproven at cix.co.uk • GMail/G+/Twitter/Flickr/Facebook: lproven
MSN: lproven at hotmail.com • Skype/AIM/Yahoo/LinkedIn: liamproven
Tel: +44 20-8685-0498 • Cell: +44 7939-087884

More information about the ubuntu-users mailing list