broken libqt4-dbus on 10-04 LTS SOLVED, sorta

Gene Heskett gheskett at
Sat Nov 3 02:52:37 UTC 2012

On Friday 02 November 2012 22:23:29 Colin Law did opine:

> On 2 November 2012 21:55, Gene Heskett <gheskett at> wrote:
> > On Friday 02 November 2012 17:41:35 Colin Law did opine:
> >>  ...
> >> 
> >> I presume you have done
> >> sudo apt-get update
> > 
> > Reloading the data in synaptic did NOT seem to effect this.
> > 
> > Doing the apt-get update, then restarting synaptic made it available
> > as a re-install option
> So not having done apt-get update after modifying sources.list back to
> what it should have been allowed the re-install to go ahead?
> >, which I did, and which didn't effect the results, most
> >
> > of my menu's are there, but do nothing when clicked on.  Is this
> > something that might require a reboot?  Come to think of it, this
> > started with the last reboot, something forced on me by excessive
> > swap usage that a "swapoff -a; swapon -a" that I need to do about
> > weekly, but after about 3 weeks, the heavy swap usage comes back in
> > half an hour and I give up & reboot the beast.  Uptime is currently
> > in the 2nd day.  I'll send this, and reboot just for S&G.
> > 
> >> Otherwise I am out of my depth I am afraid.
> > 
> > Sounds like its launchpad time then, but I've no clue what my login
> > and passwd are, its been at least a year, maybe more.
> I meant that if apt-get update did not fix the apt-get problem then I
> was out of my depth, which apparently I was not.
> The subject of this thread was why you could not reinstall the package
> so this thread appears to be solved.
> > Thanks Colin.
> Glad to be of help.
> Colin

I am now a wee tiny bit smarter.  I entered a google search for that exact 
error, which in fact seems to be entire too common, first starting at 8.04 
for a lot of folks.  Reading through the bug list on launchpad, I check 
each and every one of the scenes out in order, UNTIL I hit a small payday 
when someone mentioned GE, which installs a boat load of its own libraries 
and its startup script does an add to LD_LIBRARY_PATH by appending its 
install path it it.  I first tried moving the offending libraries to cold 
storage, but GE then will not run.  So I moved them back, and it runs 
again.  BUT after running it in a shell I ask it to "echo $LD_LIBRARY_PATH" 
and its empty!  It appears I can mv /etv/ which 
adds that path to the ldconfig output, but that will probably kill GE 
again.  But it didn't!  It did do a very voluable crash report on quitting 
though. :)  And it will not run again, issueing a crash report this time.

But GE be damned, the menus are alive and apparently working in the couple 
of tests I've run.

Ok, time to carry this bucket of well seasoned coals to Mountain View & 
dump them on googles front step.

It appears this is NOT a ubuntu problem but a google problem and I wonder 
whose libraries are newer & perhaps bigger.  A quick scan with mc shows 
that everything they have in that dir that I have in /usr/lib, is both 
older and bigger, and they don't backlink to an .so link file at all.

My sincere apologies for automatically assuming it was a ubuntu problem.

Thanks for putting up with me about this.  Too bad I can't add to that 
thread on launchpad, just read about it.

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
My web page: <> is up!
BOFH excuse #244:

Your cat tried to eat the mouse.

More information about the ubuntu-users mailing list