kernel 3.0.0-13-generic seems to be last one that works on my ASUS laptop

Robert P. J. Day rpjday at
Mon Mar 12 13:06:44 UTC 2012

On Mon, 12 Mar 2012, Liam Proven wrote:

> On 12 March 2012 12:11, Robert P. J. Day <rpjday at> wrote:
> >
> >  i have an ASUS 64-bit G74S laptop for which the most recent kernel
> > that boots properly seems to be 3.0.0-13-generic.  anything after
> > that, once i select it during grub, seems to hang the system almost
> > immediately (no HD activity, black screen).
> >
> >  i also hand-built a "git clone"d kernel from the corresponding
> > config file and, annoyingly, that also hung, so i'm back to the
> > 3.0.0-13-generic release.
> >
> >  i'm about to do more experimenting, but i'm open to suggestions.
> Check the machine's BIOS is the most current available.

  well, i ugraded the bios to what is apparently the latest version
and that didn't solve the problem so here are the symptoms.  as i
said, the 3.0.0-13-generic kernel seems to work fine.  when i tried to
boot 3.0.0-14-generic, the system froze almost immediately, so i
booted in recovery mode and could see the final line of the form:

  ... generic-usb ... Dell USB keyboard

then nothing.  so the final operation of that kernel was to recognize
my USB keyboard.  same thing with 3.0.0-15-generic.

  just in case it was the external keyboard that was causing the
problem, i unhooked both keyboard and mouse, at which point booting in
recovery mode gave me a final printed line of:

  Begin: Running /scripts/init-bottom ... new high speed USB device
number 5 using ehci_hcd

and that's it.  more interestingly, when i tried booting in recovery
mode with my hand-rolled 3.3.0-rc7 kernel, it got as far as:

  Begin: Running /scripts/init-bottom ...

and that was it.  and when i went back to the working 3.0.0-13-generic
kernel, right after that line about running init-bottom (when booting
in recovery mode), i got:

  done.  hostname start/running.

and a shell prompt shortly thereafter.  so there's something funny
going on with USB, it would appear, but i'm open to suggestions as to
what to check next.



Robert P. J. Day                                 Ottawa, Ontario, CANADA


More information about the ubuntu-users mailing list