Stephen stephen_o at
Sun Mar 11 00:06:53 UTC 2012

On 10/03/2012 4:33 PM, Nils Kassube wrote:
> Stephen wrote:
>> Hello I'm using Ubuntu 10, 11. I originally set it up in a 40gb
>> partition on a windows xp drive. I wanted to give more space to the
>> ubuntu partition.
>> I shrunk the windows partition by 30 gig, and tried to make the linux
>> partition larger but it wouldn't let me because I couldn't unmount
>> the partition.
>> So I booted from a live disk and started gparted. All I could do was
>> shrink the linux partition it wouldn't let me make it larger.
> Can you post the output of the command
> sudo fdisk -l
> in a terminal? That might help us determine the reason for the problem.
> One idea: Could it be that your Linux partition is a logical partition
> within an extended partition? Then you should first expand the extended
> partition and afterwards you should be able to expand the Linux
> partiion.
> Nils
Thank you for your response.
I tried again.
Here is the read out from sudo -l
    Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63   892377087   446188512+   7  HPFS/NTFS/exFAT
/dev/sda2       892379134   976768064    42194465+   5  Extended
/dev/sda5       973217763   976768064     1775151   82  Linux swap / Solaris
/dev/sda6       892379136   969025535    38323200   83  Linux
/dev/sda7       969027584   973215743     2094080   82  Linux swap / Solaris

I tried again to enlarge the dev/sda2. Which seems to be a container for 
all the linux partitions. It wouldn't give me the option to re-size it. 
I tried again to enlarge the dev/sda6 which is EXT4 format.

More information about the ubuntu-users mailing list